Auteur Topic: Na een error met OpenSubtitles search API in het vervolg geen OS searches meer  (gelezen 1066 keer)

Offline Satch_23

  • Bedankjes
  • -Gegeven: 17
  • -Ontvangen: 3
  • Berichten: 161
Hi Ben(V),

soms krijg ik een error met de Opensubtitles API, zoals hieronder:

23-10 20:31:19 DBG run         :No subs found with minmal match score for Once.Upon.a.Time.S07E02.HDTV.x264-SVA[eztv]
23-10 20:31:19 ERR _OS_Search  :Error from Opensubtitles search API
23-10 20:31:16 DBG _OS_Search  :Search started for 1843230.
23-10 20:31:16 DBG _A7_Search  :23 subs found, now checking them.
23-10 20:31:16 DBG get         :Url= /ajax_loadShow.php?show=1808&season=7&langs=|17|&hd=0&hi=0
23-10 20:30:56 DBG _A7_Search  :Addic7ed search started for 1808.
23-10 20:30:56 DBG getSubLinks :Imdb ID: 1843230 - Addic7ed ID: 1808 - Language: ['Dutch'] - Title: Once Upon a Time (2011)
23-10 20:30:56 INF run         :Searching downloadlink(s) for Once.Upon.a.Time.S07E02.HDTV.x264-SVA[eztv], for ['Dutch']

Vervolgens gebruikt Autosub geen Opensubtitles meer om subs te zoeken voor de nog af te handelen afleveringen. Is dit normaal en te verwachten gedrag?

Gen idee waarom de error optreedt want een volgende run kan het gewoon goed gaan zonder errors. Wellicht iets van een time-out? Of iets anders...

Enig idee?

Ben(V)

  • Gast
Het kan natuurlijk altijd voorkomen dat Opensubtitles er even uitligt, er een hikup in de verbinding is of Opensubtitles het heel erg druk heeft.
Als Autosub tegen zo'n error aanloopt stopt hij voor dat zoekrondje met het gebruik van Opensubtitles en probeert hij het volgende zoekrondje het weer opnieuw.

Dus wat je waarneemt is "as designed".

Dit gedrag is nodig omdat als Opensubtitles er echt uitligt Autosub eindeloos op timeouts van Opensubtitles zou gaan wachten terwijl hij eigenlijk betere verder kan gaan zoeken op de andere sites zoals Addic7ed.
Als Opensubtitles weer bereikbaar is herstelt zich dat gewoon weer bij het volgende zoekrondje.

Offline Satch_23

  • Bedankjes
  • -Gegeven: 17
  • -Ontvangen: 3
  • Berichten: 161
Ben(V),

dank voor je terugkoppeling. Ik vermoedde al dat het "as designed" is.
Toevallig nog mogelijk om in debug-mode aan te geven wat voor "soort" error zich heeft voorgedaan? (voornamelijk pure nieuwsgierigheid).

Zoals altijd mijn dank!

Ben(V)

  • Gast
Zal eens kijken, maar zal meestal wel een timeout zijn.


 

Auto-sub vind geen gam of thrones

Gestart door ppeeters11Board Auto-Sub

Reacties: 1
Gelezen: 1364
Laatste bericht 09 september 2015, 14:09:03
door Ben(V)
Diskstation niet meer bereikbaar onder Windows

Gestart door JanSrBoard Windows

Reacties: 5
Gelezen: 1683
Laatste bericht 23 oktober 2015, 15:42:42
door Hutje
externe verbinding werkt niet meer

Gestart door jernstBoard DDNS / Quick Connect / EZ-Internet / Portforwarding

Reacties: 0
Gelezen: 1151
Laatste bericht 26 november 2015, 09:17:57
door jernst
DSvideo alternatieven voor mijn DS216Play, Philips smart tv draait geen DSvideo.

Gestart door DeBertBoard Smart TV apps

Reacties: 10
Gelezen: 9538
Laatste bericht 23 januari 2016, 20:51:43
door Tony
Internal error

Gestart door huijshBoard Mail Station

Reacties: 0
Gelezen: 1055
Laatste bericht 31 januari 2016, 11:26:14
door huijsh