Auteur Topic: Iemand al ervaring met Docker?  (gelezen 13977 keer)

Offline Stephan296

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 43
  • -Ontvangen: 266
  • Berichten: 2.353
Re: Iemand al ervaring met Docker?
« Reactie #30 Gepost op: 23 mei 2015, 11:53:34 »
Ik vond een verhaal over de nieuwste Kodi met upnp scannen van libaries. Dus daar wil ik eens in duiken

Verstuurd vanaf mijn Nexus 5 met Tapatalk
DS415+ - 1x WD80 - 1x WD30 - 1x SSD - 8GB RAM -DSM 6.0.1-7393 Update 2
DS211+ - 1x 500 GB - 512MB RAM - DSM 6.1-14871 BETA
Synology Router RT1900AC - SRM 1.1.4-6509 Update 2

Offline Stephan296

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 43
  • -Ontvangen: 266
  • Berichten: 2.353
Re: Iemand al ervaring met Docker?
« Reactie #31 Gepost op: 05 juni 2015, 14:08:53 »
Ik heb kodi nu draaiend!
Contact gehad met de ontwikkelaar en je moet eerst met een andere kodi op bv je laptop een scan doen zodat dat naar de mysql database wordt weggeschreven en daarna kan headless kodi het zelf.
DS415+ - 1x WD80 - 1x WD30 - 1x SSD - 8GB RAM -DSM 6.0.1-7393 Update 2
DS211+ - 1x 500 GB - 512MB RAM - DSM 6.1-14871 BETA
Synology Router RT1900AC - SRM 1.1.4-6509 Update 2

Offline J-J

  • Bedankjes
  • -Gegeven: 29
  • -Ontvangen: 11
  • Berichten: 133
Re: Iemand al ervaring met Docker?
« Reactie #32 Gepost op: 18 november 2015, 23:34:11 »
Ik krijg het maar niet aan de praat. Vroeg al hulp in het "Headless Kodi-topic" op het Kodi forum, maar ktijg niet direct antwoord, dus vraag ik het hier nog maar eens. ;)

Dit werkt al:
  • Docker
  • "sparklyballs/headless-kodi-helix" image is geinstalleerd
  • Heb poorten manueel toegewezen:
    • TCP: Local 33333 / Container 8888
    • UDP: Local 33334 / Container 9777

"advancedsettings.xml" vond ik terug op 2 locaties:
  • /volume1/@appstore/Docker/docker/aufs/diff/f6abb0a0972c0efc57240c9cdcc2d9757ec5145564d795a8f23bb6cae50821e8/root
  • /volume1/@appstore/Docker/docker/aufs/diff/b5cee6428d210cc911cebac3257bb073c51e33c25f2ac6917db0a66149a5d890/opt/kodi-server/share/kodi/portable_data

De 2de locatie is waar alles moet staan.

Wat ik gedaan heb is:
  • Op mijn huidige Kodi install (PC) onder 'instellingen --> netwerk', de Webserverpoort ingesteld naar 8888 (container TCP poort) en een nieuwe user en paswoord ingevuld.
  • Van mijn huidige Kodi install de "kodi" map gekopieerd naar de "portable_data" map op mijn NAS. (C:\Users\MIJN_NAAM\AppData\Roaming\Kodi)


Hierin zit reeds mijn huidige advancedsettings.xml:

<advancedsettings>

<network>
<curlclienttimeout>45</curlclienttimeout>
</network>

<videoscanner>
<ignoreerrors>true</ignoreerrors>
</videoscanner>

<gui>
<algorithmdirtyregions>3</algorithmdirtyregions>
<nofliptimeout>0</nofliptimeout>
</gui>

<latency>
<delay>0</delay>
</latency>

<videodatabase>
<type>mysql</type>
<host>HOSTNAME.DDNS.COM</host>
<port>3306</port>
<user>xbmc</user>
<pass>xbmc</pass>
<name>kodi_video</name>
</videodatabase>

<musicdatabase>
<type>mysql</type>
<host>HOSTNAME.DDNS.COM</host>
<port>3306</port>
<user>xbmc</user>
<pass>xbmc</pass>
<name>kodi_music</name>
</musicdatabase>

<pathsubstitution>
      <substitute>
    <from>special://masterprofile/Thumbnails/</from>
      <to>smb://USER:PASSWORD@HOSTNAME.DDNS.COM/XBMCmedia/Thumbnails/</to>
    </substitute>
   
<substitute>
    <from>special://profile/sources.xml</from>
<to>smb://USER:PASSWORD@HOSTNAME.DDNS.COM/XBMCmedia/sources.xml</to>
</substitute>

<substitute>
<from>special://profile/mediasources.xml</from>
<to>USER:PASSWORD@HOSTNAME.DDNS.COM/XBMCmedia/mediasources.xml</to>
</substitute>

<substitute>
<from>special://profile/favourites.xml</from>
<to>USER:PASSWORD@HOSTNAME.DDNS.COM/XBMCmedia/favourites.xml</to>
</substitute>

<substitute>
<from>special://profile/playlists/</from>
<to>smb://USER:PASSWORD@HOSTNAME.DDNS.COM/XBMCmedia/playlists/</to>
</substitute>

<substitute>
<from>special://profile/passwords.xml</from>
<to>smb://USER:PASSWORD@HOSTNAME.DDNS.COM/XBMCmedia/passwords.xml</to>
</substitute>
</pathsubstitution>

<videolibrary>
<importwatchedstate>true</importwatchedstate>
</videolibrary>

</advancedsettings>

Ik denk dat daar mijn fout ook zit:

De advancedsettings.xml op de NAS toont dit standaard:
Citaat
<advancedsettings>

<!--
#####################################################

############ DON'T EDIT OR DELETE THIS BLOCK ######## 
-->

<videodatabase>
<type>mysql</type> 
<host></host> 
<port></port> 
<user></user> 
<pass></pass> 
</videodatabase>
<musicdatabase>
<type>mysql</type> 
<host></host> 
<port></port> 
<user></user> 
<pass></pass> 
</musicdatabase>


<services>
<devicename>XBMC Server</devicename>
<esallinterfaces>false</esallinterfaces>
<escontinuousdelay>25</escontinuousdelay>
<esenabled>true</esenabled>
<esinitialdelay>750</esinitialdelay>
<esmaxclients>20</esmaxclients>
<esport>9777</esport>
<esportrange>10</esportrange>
<upnpannounce>true</upnpannounce>
<upnprenderer>false</upnprenderer>
<upnpserver>true</upnpserver>
<webserver>true</webserver>
<webserverpassword>xbmc</webserverpassword>
<webserverport>8080</webserverport>
<webserverusername>xbmc</webserverusername>
<webskin>webinterface.default</webskin>
<zeroconf>true</zeroconf>
</services>

<!--
############ OR THINGS WILL BREAK ###################

#####################################################



########### THINGS BELOW ARE HOWEVER EDITABLE #######
refer to http://kodi.wiki/view/Advancedsettings.xml for info on the various settings -->





<videolibrary>
<importresumepoint>true</importresumepoint>    <!-- import previously exported resume point from .nfo files -->
<importwatchedstate>true</importwatchedstate>  <!-- import previously exported playdate and playcount from .nfo files -->
<backgroundupdate>true</backgroundupdate>
<dateadded>0</dateadded> <!-- 0 results in using the current datetime when adding a video;
                              1 (default) results in prefering to use the files mtime (if it's valid) and only using the file's ctime if the mtime isn't valid;
                              2 results in using the newer datetime of the file's mtime and ctime -->

</videolibrary>
<musiclibrary>
<backgroundupdate>true</backgroundupdate>
</musiclibrary>
<videoscanner>
<ignoreerrors>true</ignoreerrors> <!-- Set to true to silently ignore errors while scanning videos. This prevents the error dialogue box, so you don't have to keep hitting "yes" to keep scanning.-->
</videoscanner>
<splash>false</splash>
<bginfoloadermaxthreads>2</bginfoloadermaxthreads>
<myvideos>
<extractflags>false</extractflags>
<extractthumb>false</extractthumb>
</myvideos>
<lookandfeel>
<enablerssfeeds>false</enablerssfeeds>
</lookandfeel>
<audiooutput>
<guisoundmode>0</guisoundmode>
<ac3passthrough>false</ac3passthrough>
<dtspassthrough>false</dtspassthrough>
<multichannellpcm>false</multichannellpcm>
<truehdpassthrough>false></truehdpassthrough>
<dtshdpassthrough>false</dtshdpassthrough>
<mode>2</mode>
</audiooutput>
<videoscreen>
<vsync>2</vsync>
</videoscreen>
<input>
<enablemouse>false</enablemouse>
<remoteaskeyboard>false</remoteaskeyboard>
</input>
<general>
<addonnotifications>false</addonnotifications>
</general>
<skinsettings>
<setting type="bool" name="skin.confluence.FirstTimeRun">false</setting>
</skinsettings>
</advancedsettings>

Een deel heb ik al in mijn eigen advancedsettings.xml staan (groene kleur), maar mar mag blijkbaar niet aangepast worden...

Heb ik teveel mappen gekopieerd of mag enkel de advancedsettings.xml gekopieerd worden? En wat moet ik erin zetten?

Als iemand me kan helpen?

Bedankt!
  • Mijn Synology: DS412+
  • HDD's: 4x ST4000VN000
  • Extra's: 2GB DDR3 / DSM5.2

Offline Stephan296

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 43
  • -Ontvangen: 266
  • Berichten: 2.353
Re: Iemand al ervaring met Docker?
« Reactie #33 Gepost op: 18 november 2015, 23:37:18 »
Je moet alleen de advancedsettings.XML hebben en de source.xml.

Verder mag je database geen naam hebben zoals kodivideo en kodiaudio.
Tevens moet je die credits al in Docker zelf invoeren. Staat ook op dat forum waar je het al hebt gevraagd ;-)
DS415+ - 1x WD80 - 1x WD30 - 1x SSD - 8GB RAM -DSM 6.0.1-7393 Update 2
DS211+ - 1x 500 GB - 512MB RAM - DSM 6.1-14871 BETA
Synology Router RT1900AC - SRM 1.1.4-6509 Update 2

Offline J-J

  • Bedankjes
  • -Gegeven: 29
  • -Ontvangen: 11
  • Berichten: 133
Re: Iemand al ervaring met Docker?
« Reactie #34 Gepost op: 19 november 2015, 16:24:27 »
Stond inderdaad heel wat uitleg al in het topic ;D :

Citaat van: 'MuzzleAU'
I've got it working on my Synology DS1511 using that version (BTW nice job Sparklyballz).

There's a few things you need to set up on the Synology Docker UI. Click the 'Edit' button on the 'Container' tab and...
1. On the 'Basic Options' tab, click '+' to add a port mapping. The default web port is 8080, so I made a mapping from local port 8008 to container port 8080 to avoid any conflicts with my NAS.
2. On the 'Environment Variables' tab, add the login settings for your MySQL database; these variables are named 'MYSQLip', 'MYSQLport', 'MYSQLuser', 'MYSQLpass'.
3. On the 'Volume' tab, you might want to add a mount for the Thumbnails if you're using a shared folder across all your PCs.

Incidentally, the default login / pass to the web interface is 'xbmc'/'xbmc'.

This is likely enough if you're using the default database names (eg. MyVideo##). Unfortunately in my case, I have non-standard names as a result of following this guide, and had to SSH into the container and make manual adjustments.

Dat heb ik allemaal gedaan.

Vervolgens heb ik het volgende gedaan:
  • De naam van de database in phpMyAdmin aangepast naar de standaard benaming, MyVideos93 & MyMusic52
  • De "<name>-tag" in advancedsettings.xml verwijderd.
  • sources.xml en passwords.xml naar de userdata folder op de NAS gekopieerd. ('/volume1/@appstore/Docker/docker/aufs/diff/b5cee6428d210cc911cebac3257bb073c51e33c25f2ac6917db0a66149a5d890/opt/kodi-server/share/kodi/portable_data')
  • Addons die er standaard niet bij zaten gekopieerd naar de NAS (alsook de desbetreffende 'addon-data' (Universal movie scraper, AniDB.net.mod, trakt)
  • In advancedsettings.xml heb ik enkel dit onderaan toegevoegd.
    Citaat
    <pathsubstitution>
            <substitute>
              <from>special://masterprofile/Thumbnails/</from>
               <to>smb://HOSTNAME.DDNS.COM/XBMCmedia/Thumbnails/</to>
           </substitute>
        </pathsubstitution>
    Ik weet niet of dit zin heeft, omdat ik in de docker instellingen reeds dit ingaf?

Als ik de headless Kodi opstart kan ik naar de Webserver gaan (ip.van.de.nas:8008), maar hier staat nog steeds niets in (Op PC heb ik al enkele sources gescand en dan kodi terug uitgezet).
Als ik op Movies, TV Shows of Music ofzo druk zie ik bovenaan het "spinningwheel". Als ik op Profile druk krijg ik een foutmelding: "Connection to server lost"

Dit is mijn log:
*** Shutting down runit daemon (PID 17)...
stdout
14:45:02
*** Killing all processes...
stdout
14:45:07
*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
stdout
14:45:07
*** Running /etc/my_init.d/firstrun.sh...
stdout
14:45:07
using existing datafiles
stdout
14:45:08
using existing advancedsettings.xml
stdout
14:45:09
*** Running /etc/rc.local...
stdout
14:45:09
*** Booting runit daemon...
stdout
14:45:09
*** Runit started as PID 14
stdout
14:45:09
Can't open display
stdout
14:45:10
Nov 19 14:45:09 Kodi-Helix syslog-ng[21]: syslog-ng starting up; version='3.5.3'
stdout
14:45:21
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:21
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:22
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:34
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:34
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:36
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:36
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:36
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:37
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:37
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:37
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:38
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:40
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:40
tdb(__NULL__): tdb_open_ex: called with name == NULL
stdout
14:45:41
tdb(__NULL__): tdb_open_ex: called with name == NULL

Het werkt dus nog steeds niet...
Wat ik me ook afvroeg, hoe weet Kodi Headless welke sources Series en welke films zijn? Of staat dat in de DB in phpMyAdmin
  • Mijn Synology: DS412+
  • HDD's: 4x ST4000VN000
  • Extra's: 2GB DDR3 / DSM5.2

Offline Stephan296

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 43
  • -Ontvangen: 266
  • Berichten: 2.353
Re: Iemand al ervaring met Docker?
« Reactie #35 Gepost op: 19 november 2015, 18:00:15 »
Begin nou eens met een schone lei en niet met andere namen, oude databases en dat soort zaken.
Als je die omschrijving volgt en je laat eerst door een bestaande kodi installatie die database vullen dan pakt hij het vanzelf op. Echter de database daarna bij laten werken kan door commando's gebeuren vanuit bv sickrage.
DS415+ - 1x WD80 - 1x WD30 - 1x SSD - 8GB RAM -DSM 6.0.1-7393 Update 2
DS211+ - 1x 500 GB - 512MB RAM - DSM 6.1-14871 BETA
Synology Router RT1900AC - SRM 1.1.4-6509 Update 2

Offline J-J

  • Bedankjes
  • -Gegeven: 29
  • -Ontvangen: 11
  • Berichten: 133
Iemand al ervaring met Docker?
« Reactie #36 Gepost op: 05 februari 2016, 01:02:25 »
Was het proberen beu, maar vandaag toch nog eens geprobeerd Kodi-Headless te draaien op mijn NAS.
Uiteindelijk ook gevonden wat het voornaamste probleem was. Ik draaide de Helix versie, terwijl alle andere clients Isengard draaiden. (andere database versie)
Heb dus een nieuwe image gedownload (sparklyballs/headless-kodi-isengard) en na aanpassing van de advancedsettings.xml, heb ik toegang tot mijn database.

Het enige probleem dat ik heb, is dat er zo goed als geen cover art verschijnt. Duurt het soms lang voor alles geladen is?
In de advancedsettings.xml laat ik deze via "pathsubstitution" naar een locatie op mijn NAS downloaden.
<pathsubstitution>
     <substitute>
    <from>special://masterprofile/Thumbnails/</from>
     <to>nfs://mijn.ip.adres/volume1/XBMCmedia/Thumbnails/</to>
    </substitute>
   <substitute>
    <from>special://profile/sources.xml</from>
<to>nfs://mijn.ip.adres/volume1/XBMCmedia/sources.xml</to>
</substitute>
<substitute>
<from>special://profile/mediasources.xml</from>
<to>nfs://mijn.ip.adres/volume1/XBMCmedia/mediasources.xml</to>
</substitute>
<substitute>
<from>special://profile/favourites.xml</from>
<to>nfs://mijn.ip.adres/volume1/XBMCmedia/favourites.xml</to>
</substitute>
<substitute>
<from>special://profile/playlists/</from>
<to>nfs://mijn.ip.adres/volume1/XBMCmedia/playlists/</to>
</substitute>
<substitute>
<from>special://profile/passwords.xml</from>
<to>nfs://mijn.ip.adres/volume1/XBMCmedia/passwords.xml</to>
</substitute>
</pathsubstitution>

Heeft dat er iets mee te maken, of moet ik naar deze locatie verwijzen in de container? Hoe doe ik dat dan?

Heb nog een bijkomende vraag. Ik probeerde een andere webinterface uit, nl. "Arch". Ondanks dat hij lade, gaf hij mijn media niet weer. Is dit omdat het niet de bedoeling is de standaard webinterface aan te passen of doe ik iets verkeerd? (duurt het misschien extreem lang voor media weergegeven wordt)
  • Mijn Synology: DS412+
  • HDD's: 4x ST4000VN000
  • Extra's: 2GB DDR3 / DSM5.2

Offline Stephan296

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 43
  • -Ontvangen: 266
  • Berichten: 2.353
Re: Iemand al ervaring met Docker?
« Reactie #37 Gepost op: 05 februari 2016, 08:45:15 »
Probleem had ik ook met die covers. Was een nfs rechten probleem.
Als die goed staat dan moet het in principe werken.
Omdat hij met een heel ander ip adres verbinding maakt (hele andere range dan intern netwerk) pakte hij de covers niet op.
DS415+ - 1x WD80 - 1x WD30 - 1x SSD - 8GB RAM -DSM 6.0.1-7393 Update 2
DS211+ - 1x 500 GB - 512MB RAM - DSM 6.1-14871 BETA
Synology Router RT1900AC - SRM 1.1.4-6509 Update 2

Offline J-J

  • Bedankjes
  • -Gegeven: 29
  • -Ontvangen: 11
  • Berichten: 133
Re: Iemand al ervaring met Docker?
« Reactie #38 Gepost op: 05 februari 2016, 09:13:07 »
NFS staat zo ingesteld dat hij elke IP adres aanvaard. ("*")



  • Mijn Synology: DS412+
  • HDD's: 4x ST4000VN000
  • Extra's: 2GB DDR3 / DSM5.2

Offline Stephan296

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 43
  • -Ontvangen: 266
  • Berichten: 2.353
Re: Iemand al ervaring met Docker?
« Reactie #39 Gepost op: 05 februari 2016, 10:49:26 »
En de rechten van de map waarin de films en series staan? Die moesten bij mij op 777 staan
DS415+ - 1x WD80 - 1x WD30 - 1x SSD - 8GB RAM -DSM 6.0.1-7393 Update 2
DS211+ - 1x 500 GB - 512MB RAM - DSM 6.1-14871 BETA
Synology Router RT1900AC - SRM 1.1.4-6509 Update 2

Offline J-J

  • Bedankjes
  • -Gegeven: 29
  • -Ontvangen: 11
  • Berichten: 133
Re: Iemand al ervaring met Docker?
« Reactie #40 Gepost op: 05 februari 2016, 11:09:46 »
Heb het aangepast, maar het verandert niets.

</volume 1>:
drwxrwxrwx 1503 root     root        724992 Feb  3 23:51 Films
drwxrwxrwx  145 root     root          4096 Feb  3 05:59 Series
drwxrwxrwx    9 root     root          4096 Jan 13 20:44 XBMCmedia

</volume1/Films>:
drwxrwxrwx    2 Saidou   users         4096 Nov 14 01:39 The Lucky One (2012)
drwxrwxrwx    2 couchpot users         4096 Dec  8 02:01 The Man from U.N.C.L.E. (2015)
drwxrwxrwx    2 Saidou   users         4096 Nov 14 01:39 The Man with the Iron Fists (2012)
drwxrwxrwx    2 transmis users         4096 Dec 30 08:06 The Martian (2015)

</volume1/Series>:
drwxrwxrwx    4 sickrage users         4096 Nov 13 18:01 The Whispers
drwxrwxrwx    4 nzbdrone users         4096 Jan 27 13:50 The X-Files
drwxrwxrwx    4 sublimin users         4096 Nov 13 18:24 Transporter
drwxrwxrwx    6 admin    users         4096 Nov 13 18:01 True Detective

</volume1/XBMCmedia>:
drwxrwxrwx    9 root     root          4096 Jan 13 20:44 .
drwxr-xr-x   50 root     root          4096 Feb  5 00:03 ..
-rwxrwxrwx    1 admin    users         8196 Dec 30 05:35 .DS_Store
drwxrwxrwx    4 Saidou   users         4096 Dec 30 05:44 .TemporaryItems
drwxrwxrwx    3 root     users         4096 Feb  5 00:03 @eaDir
-rwxrwxrwx    1 Saidou   users     96099000 Dec  5 12:10 Kodi_settings_clean.zip
drwxrwxrwx    3 admin    users         4096 May  7  2014 Logs
drwxrwxrwx    3 admin    users         4096 Dec 26 02:00 Plug-ins and repos
drwxrwxrwx   19 nobody   users         4096 Sep 25  2014 Thumbnails
-rwxrwxrwx    1 Saidou   users         1659 Jan  6 21:05 advancedsettings.xml.bak
drwxrwxrwx    5 Saidou   users         4096 Dec 30 06:45 backups
-rwxrwxrwx    1 Saidou   users          134 Dec 28 02:50 mediasources.xml
-rwxrwxrwx    1 Saidou   users          209 Nov 17 17:57 mediasources.xml.remote
-rwxrwxrwx    1 Saidou   users          664 Dec 28 06:26 passwords.xml
drwxrwxrwx    5 admin    users         4096 Jan  2 01:29 playlists
-rwxrwxrwx    1 Saidou   users        11832 Dec 27 01:13 profile2 backup.zip
-rwxrwxrwx    1 Saidou   users         1851 Dec 28 06:26 sources.xml
-rwxrwxrwx    1 Saidou   users         1477 Dec 12 15:44 sources.xml.remote
  • Mijn Synology: DS412+
  • HDD's: 4x ST4000VN000
  • Extra's: 2GB DDR3 / DSM5.2

Offline Stephan296

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 43
  • -Ontvangen: 266
  • Berichten: 2.353
Re: Iemand al ervaring met Docker?
« Reactie #41 Gepost op: 05 februari 2016, 12:46:36 »
Blijft vreemd dat het hier perfect draait en bij jou het niet wil.
Ik wil van het weekend wel een keer via teamviewer meekijken. Dan kunnen we even alles nalopen
DS415+ - 1x WD80 - 1x WD30 - 1x SSD - 8GB RAM -DSM 6.0.1-7393 Update 2
DS211+ - 1x 500 GB - 512MB RAM - DSM 6.1-14871 BETA
Synology Router RT1900AC - SRM 1.1.4-6509 Update 2

Offline J-J

  • Bedankjes
  • -Gegeven: 29
  • -Ontvangen: 11
  • Berichten: 133
Re: Iemand al ervaring met Docker?
« Reactie #42 Gepost op: 07 februari 2016, 14:07:14 »
Bedankt voor het voorstel @Stephan296 .
Ik heb het probleem ondertussen gevonden. Blijkbaar had ikzelf, als gebruiker én admin niet de juiste rechten op bepaalde mappen. Heb dit nu aangepast en de covert art verschijnt.

Ik kan de database echter niet automatisch laten updaten...

Heb 2 zaken geprobeerd:
  • Sonarr & Couchpotato instellen
    • Sonarr:
    • Couchpotato:
  • "Library Auto Update" aan Kodi op mijn PC toegevoegd en dan de addon + settings naar de headless Kodi gekopieerd. Deze staat ingesteld dat hij om de 6u een refresh moet doen.

Vannacht is er een nieuwe aflevering "binnengekomen", maar deze werd niet aan mijn Kodi library toegevoegd...
  • Mijn Synology: DS412+
  • HDD's: 4x ST4000VN000
  • Extra's: 2GB DDR3 / DSM5.2

Offline Stephan296

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 43
  • -Ontvangen: 266
  • Berichten: 2.353
Re: Iemand al ervaring met Docker?
« Reactie #43 Gepost op: 07 februari 2016, 14:20:13 »
Wat doe je toch moeilijk met add ons installeren.
Dat heb je helemaal niet nodig.
ik kijk zo even naar je settings, dan bekijk ik ze even op mijn laptop.
UPDATE:

Je settings zien er goed uit maar je haalt 2 dingen door elkaar.
Sonarr en Couch sturen zelf het update signaal naar de headless kodi.
Doordat jij weer settings gaat kopieren van je installaties naar je headless kodi ga je dingen door de war schoppen.
Waarom zou je een auto update willen als couch en sonarr zelf de libary update?
DS415+ - 1x WD80 - 1x WD30 - 1x SSD - 8GB RAM -DSM 6.0.1-7393 Update 2
DS211+ - 1x 500 GB - 512MB RAM - DSM 6.1-14871 BETA
Synology Router RT1900AC - SRM 1.1.4-6509 Update 2

Offline J-J

  • Bedankjes
  • -Gegeven: 29
  • -Ontvangen: 11
  • Berichten: 133
Re: Iemand al ervaring met Docker?
« Reactie #44 Gepost op: 07 februari 2016, 15:36:36 »
Ik heb de addons en hun settings verwijderd. Nu even wachten of het lukt. Thanks voor de hulp alvast.
  • Mijn Synology: DS412+
  • HDD's: 4x ST4000VN000
  • Extra's: 2GB DDR3 / DSM5.2


 

Iemand oudere versie dan Logitech Media Server Versie: 7.7.3 ?

Gestart door renemBoard Logitech Media Server

Reacties: 24
Gelezen: 5762
Laatste bericht 13 augustus 2014, 16:36:12
door Birdy
Zoek contact met iemand die VPN (L2TP/IPsec ) heeft werken met UBEE Ziggo.

Gestart door 53Starter91Board NAS hardware vragen

Reacties: 14
Gelezen: 9429
Laatste bericht 10 september 2014, 17:08:24
door rpberretty
Iemand enig idee waar deze inlogpogingen vandaan komen?

Gestart door Ron53Board Synology DSM 5.1 en eerder

Reacties: 6
Gelezen: 3694
Laatste bericht 21 januari 2015, 08:35:47
door Birdy
Weet er iemand waar ik Wake On LAN Gateway package 1.0-0008.spk kan downloaden

Gestart door fiatuno49Board Algemeen

Reacties: 1
Gelezen: 222
Laatste bericht 30 oktober 2016, 21:32:37
door Birdy
Heeft iemand httpd.conf-user bestand voor mij?

Gestart door r00nBoard Web Station

Reacties: 2
Gelezen: 1086
Laatste bericht 04 mei 2013, 14:28:35
door r00n
Synology-Forum.nl is een Nederlands gebruikersforum en staat volledig los van het merk Synology.