Auteur Topic: MariaDB 10 failed to run the package service  (gelezen 833 keer)

Offline YoeriVlas

  • Bedankjes
  • -Gegeven: 2
  • -Ontvangen: 0
  • Berichten: 5
MariaDB 10 failed to run the package service
« Gepost op: 15 oktober 2018, 17:41:14 »
Na een crash van een DS1515+ (moederbord defect na een stroompanne) heb ik de schijven verplaatst naar een nieuwe DS1517+. Alles werkt terug zoals voorheen, parity check = ok. Enkel de MariaDB wil niet opstarten: "Failed to run the package service".
Na rond googelen voor een oplossing en verschillende dingen uitgetest te hebben, krijg ik hem nog steeds niet aan de praat.

Ondernomen:
- MariaDB 5 en 10 verwijderen (zonder de database te verwijderen) en rebooten: no joy
- via ssh de my.cnf aangepast (/usr/local/mariadb10/etc/mysql/my.cnf) door het bind-address aan te passen naar 127.0.0.1, in commentaar te plaatsen, poort aan te passen van 3307 naar 3306, enz. : no joy
- controle errlog:mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended
- in de my.cnf can ik deze pid file wel aantreffen, maar weet niet juist wat moet eventueel aangepast worden.

Iemand die mij verder kan helpen?

Alvast bedankt,
Yoeri
  • Mijn Synology: DS1517+

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 950
  • -Ontvangen: 5170
  • Berichten: 30.766
  • Synology is awesome.
    • Synology Support
Re: MariaDB 10 failed to run the package service
« Reactie #1 Gepost op: 15 oktober 2018, 18:33:00 »
De mysqld.pid wordt gemaakt als MariaDB gestart is, staat daar het Process ID er niet in?
Kan je die pid ook niet terug vinden als Process?
Veel mensen weten veel, maar niemand weet alles.


CS406     2 x HDS721075KLA330 DSM 2.0-0731       [ARCHIEF OPSLAG]
          ST3750640AS HD753LJ
DS107+    HDS722020ALA330     DSM 3.1-1639       [ARCHIEF OPSLAG]
DS111     WD40EZRZ            DSM 6.1.7-15284-3  [ARCHIEF OPSLAG]
DS411slim Wisselende HD's     DSM 6.2.1-23824-1  [SPEELTJE]
DS411+II  4 x HDS724040ALE640 DSM 6.1.7-15284-3  [PROD]
DS413j    4 x WD20EARX        DSM 6.1.7-15284-3  [BACKUP]
DS716+II  2 x DT01ACA050      DSM 6.2.2-24922    [TEST]
RT2600ac                      SRM 1.2.2-7915     [PROD]
MR2200ac                      SRM 1.2.2-7915     [PROD]

Offline YoeriVlas

  • Bedankjes
  • -Gegeven: 2
  • -Ontvangen: 0
  • Berichten: 5
Re: MariaDB 10 failed to run the package service
« Reactie #2 Gepost op: 16 oktober 2018, 09:12:15 »
Neen, de MariaDB start niet op. Hij begint op te starten, blijft dan wat hangen en nadien komt de melding uit het onderwerp.
  • Mijn Synology: DS1517+

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 950
  • -Ontvangen: 5170
  • Berichten: 30.766
  • Synology is awesome.
    • Synology Support
Re: MariaDB 10 failed to run the package service
« Reactie #3 Gepost op: 16 oktober 2018, 09:31:19 »
Ik heb gezocht op "mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended" (de enige error die je gegeven hebt) en vond dit Topic (gaat wel over het fedora OS, maar zal op hetzelfde neer kunnen komen).
Aan het einde blijkt de oplossing te zijn: het verwijderen van /var/lib/mysql/*

Dit is maar een voorbeeld, er zijn meer resultaten te vinden als je zoekt op "mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended"

Veel mensen weten veel, maar niemand weet alles.


CS406     2 x HDS721075KLA330 DSM 2.0-0731       [ARCHIEF OPSLAG]
          ST3750640AS HD753LJ
DS107+    HDS722020ALA330     DSM 3.1-1639       [ARCHIEF OPSLAG]
DS111     WD40EZRZ            DSM 6.1.7-15284-3  [ARCHIEF OPSLAG]
DS411slim Wisselende HD's     DSM 6.2.1-23824-1  [SPEELTJE]
DS411+II  4 x HDS724040ALE640 DSM 6.1.7-15284-3  [PROD]
DS413j    4 x WD20EARX        DSM 6.1.7-15284-3  [BACKUP]
DS716+II  2 x DT01ACA050      DSM 6.2.2-24922    [TEST]
RT2600ac                      SRM 1.2.2-7915     [PROD]
MR2200ac                      SRM 1.2.2-7915     [PROD]

Offline Ben(V)

  • MVP
  • *
  • Bedankjes
  • -Gegeven: 74
  • -Ontvangen: 1656
  • Berichten: 9.580
Re: MariaDB 10 failed to run the package service
« Reactie #4 Gepost op: 16 oktober 2018, 10:18:15 »
Waarschijnlijk staat de oude pidfile er nog want je systeem is gecrashed.
Daardoor wil het package niet meer starten vermoed ik.

Bij normaal afsluiten wordt namelijk de pidfile opgeruimd.
  • Mijn Synology: DS414
  • HDD's: 4 x 3TB WD30EFRX
  • Extra's: DS116
All truth passes through three stages: First it is ridiculed, second it is violently opposed and third it is accepted as being self-evident.

Offline YoeriVlas

  • Bedankjes
  • -Gegeven: 2
  • -Ontvangen: 0
  • Berichten: 5
Re: MariaDB 10 failed to run the package service
« Reactie #5 Gepost op: 16 oktober 2018, 11:01:32 »
Bedankt Ben en Birdy om mee te denken.

Ik ben gaan kijken naar de /var/lib en er was geen mysql folder aanwezig. Heb hem aangemaakt, maar maakt ook geen verschil.
Ik heb ook gevonden dat deze fout kan voorkomen indien er een probleem was met de initialisatie van de mysql database. Het starten van /usr/bin/mysqld_safe geeft bijkomende errors dat er reeds een mysql instantie draait.

Vermoedelijk zit de oplossing dus inderdaad in het antwoord van Ben. Mijn oud systeem (DS1515+) was gecrasht door een stroomonderbreking waarbij een stroomstoot het moederbord had verwoest. De disks waren intact bij het plaatsen in een nieuwe DS1517+ en na parity check. De DS1517+ vroeg mij bij installatie om de configuratie van mijn oud toestel over te nemen. Het kan dus inderdaad zijn dat er nog ergens een oude pidfile is meegenomen.

Dus mijn bijkomende vraag is: waar kan ik de pidfile normaal vinden en ik vermoed dus eens gevonden, deze gewoon verwijderen, rebooten en opnieuw de MariaDB 10 proberen te starten?
  • Mijn Synology: DS1517+

Offline YoeriVlas

  • Bedankjes
  • -Gegeven: 2
  • -Ontvangen: 0
  • Berichten: 5
Re: MariaDB 10 failed to run the package service
« Reactie #6 Gepost op: 16 oktober 2018, 11:40:43 »
de pidfile kwam blijkbaar van de MariaDB 5. Ik heb deze gestopt, alsook de pidfile verwijderd.
Na reboot niets meer in /var/run/mysqld.

Bij het starten van enkel MariaDB10 nog steeds hetzelfde probleem: probeert op te starten en dan de vermelding "failed to run the package service".
geen entry in /var/run/mysqld, maar ook geen errors meer...???
  • Mijn Synology: DS1517+

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 950
  • -Ontvangen: 5170
  • Berichten: 30.766
  • Synology is awesome.
    • Synology Support
Re: MariaDB 10 failed to run the package service
« Reactie #7 Gepost op: 16 oktober 2018, 12:09:34 »
Dan zou ik MariaDB weer verwijderen, reboot en opnieuw installeren.
Veel mensen weten veel, maar niemand weet alles.


CS406     2 x HDS721075KLA330 DSM 2.0-0731       [ARCHIEF OPSLAG]
          ST3750640AS HD753LJ
DS107+    HDS722020ALA330     DSM 3.1-1639       [ARCHIEF OPSLAG]
DS111     WD40EZRZ            DSM 6.1.7-15284-3  [ARCHIEF OPSLAG]
DS411slim Wisselende HD's     DSM 6.2.1-23824-1  [SPEELTJE]
DS411+II  4 x HDS724040ALE640 DSM 6.1.7-15284-3  [PROD]
DS413j    4 x WD20EARX        DSM 6.1.7-15284-3  [BACKUP]
DS716+II  2 x DT01ACA050      DSM 6.2.2-24922    [TEST]
RT2600ac                      SRM 1.2.2-7915     [PROD]
MR2200ac                      SRM 1.2.2-7915     [PROD]

Offline YoeriVlas

  • Bedankjes
  • -Gegeven: 2
  • -Ontvangen: 0
  • Berichten: 5
Re: MariaDB 10 failed to run the package service
« Reactie #8 Gepost op: 16 oktober 2018, 12:21:28 »
Heb ik geprobeerd (incl. reboot) maar met zelfde resultaat.
Bij de installatie van MariaDB kies ik wel voor het gebruiken van mijn bestaande database omdat ik mijn website wil behouden. Vermoedelijk ligt daar ergens het probleem.
  • Mijn Synology: DS1517+

Offline RobertAthome

  • Bedankjes
  • -Gegeven: 3
  • -Ontvangen: 2
  • Berichten: 29
Re: MariaDB 10 failed to run the package service
« Reactie #9 Gepost op: 22 april 2019, 13:53:39 »
Ik heb hetzelfde probleem.

Alle MariaDB versies verwijderd.
Herstart Synology
MariaDB10 geinstalleerd zelfde melding als in het onderwerp.

Zit te denken aan het herinstallatie van Synology echter 3/4 TB schijf heb ik zo niet liggen.

  • Mijn Synology: DS1515+
  • HDD's: 5x WD RED 3TB
  • Extra's: 6GB, DSM6.2.2-24922
DS411J, 2x Sam. 2TB HD204UI, 128MB, DSM6.2.2-24922

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 950
  • -Ontvangen: 5170
  • Berichten: 30.766
  • Synology is awesome.
    • Synology Support
Re: MariaDB 10 failed to run the package service
« Reactie #10 Gepost op: 22 april 2019, 14:47:03 »
Kijk eens of er nog een oude pid file bestaat in: /run/mysqld/mysqld10.pid
Veel mensen weten veel, maar niemand weet alles.


CS406     2 x HDS721075KLA330 DSM 2.0-0731       [ARCHIEF OPSLAG]
          ST3750640AS HD753LJ
DS107+    HDS722020ALA330     DSM 3.1-1639       [ARCHIEF OPSLAG]
DS111     WD40EZRZ            DSM 6.1.7-15284-3  [ARCHIEF OPSLAG]
DS411slim Wisselende HD's     DSM 6.2.1-23824-1  [SPEELTJE]
DS411+II  4 x HDS724040ALE640 DSM 6.1.7-15284-3  [PROD]
DS413j    4 x WD20EARX        DSM 6.1.7-15284-3  [BACKUP]
DS716+II  2 x DT01ACA050      DSM 6.2.2-24922    [TEST]
RT2600ac                      SRM 1.2.2-7915     [PROD]
MR2200ac                      SRM 1.2.2-7915     [PROD]

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 950
  • -Ontvangen: 5170
  • Berichten: 30.766
  • Synology is awesome.
    • Synology Support
Re: MariaDB 10 failed to run the package service
« Reactie #11 Gepost op: 22 april 2019, 14:53:58 »
En check de logfile: /var/packages/MariaDB10/target/mysql/<NAAM NAS>.err
Veel mensen weten veel, maar niemand weet alles.


CS406     2 x HDS721075KLA330 DSM 2.0-0731       [ARCHIEF OPSLAG]
          ST3750640AS HD753LJ
DS107+    HDS722020ALA330     DSM 3.1-1639       [ARCHIEF OPSLAG]
DS111     WD40EZRZ            DSM 6.1.7-15284-3  [ARCHIEF OPSLAG]
DS411slim Wisselende HD's     DSM 6.2.1-23824-1  [SPEELTJE]
DS411+II  4 x HDS724040ALE640 DSM 6.1.7-15284-3  [PROD]
DS413j    4 x WD20EARX        DSM 6.1.7-15284-3  [BACKUP]
DS716+II  2 x DT01ACA050      DSM 6.2.2-24922    [TEST]
RT2600ac                      SRM 1.2.2-7915     [PROD]
MR2200ac                      SRM 1.2.2-7915     [PROD]

Offline RobertAthome

  • Bedankjes
  • -Gegeven: 3
  • -Ontvangen: 2
  • Berichten: 29
Re: MariaDB 10 failed to run the package service
« Reactie #12 Gepost op: 22 april 2019, 15:16:53 »
Helaas geen Log en geen PID.

Wel log van MariaDB10 package

Starting MariaDB.190422 15:12:19 mysqld_safe Logging to '/var/packages/MariaDB10/target/mysql/DiskStation.err'.
190422 15:12:19 mysqld_safe Starting mysqld daemon with databases from /var/packages/MariaDB10/target/mysql
 ERROR!
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/run/mysqld/mysqld10.sock' (2)
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/run/mysqld/mysqld10.sock' (2)
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/run/mysqld/mysqld10.sock' (2)
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/run/mysqld/mysqld10.sock' (2)
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/run/mysqld/mysqld10.sock' (2)
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/run/mysqld/mysqld10.sock' (2)
 ERROR! MariaDB server PID file could not be found!
2019/04/22 15:12:20 install MariaDB10 10.3.7-0051 End postinst ret=[0]
2019/04/22 15:12:20 install MariaDB10 10.3.7-0051 Begin /bin/rm -rf /volume1/@tmp/pkginstall
2019/04/22 15:12:20 install MariaDB10 10.3.7-0051 End /bin/rm -rf /volume1/@tmp/pkginstall ret=[0]
2019/04/22 15:13:14 install MariaDB10 10.3.7-0051 Begin start-stop-status start
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
Starting MariaDB.190422 15:13:15 mysqld_safe Logging to '/var/packages/MariaDB10/target/mysql/DiskStation.err'.
190422 15:13:15 mysqld_safe Starting mysqld daemon with databases from /var/packages/MariaDB10/target/mysql
 ERROR!
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
2019/04/22 15:13:32 install MariaDB10 10.3.7-0051 End start-stop-status start ret=[1]
2019/04/22 15:13:33 (system) trigger MariaDB10 10.3.7-0051 Begin start-stop-status stop
 ERROR! MariaDB is not running, but lock file (/var/lock/subsys/mysql) exists
2019/04/22 15:13:33 (system) trigger MariaDB10 10.3.7-0051 End start-stop-status stop ret=[0]
  • Mijn Synology: DS1515+
  • HDD's: 5x WD RED 3TB
  • Extra's: 6GB, DSM6.2.2-24922
DS411J, 2x Sam. 2TB HD204UI, 128MB, DSM6.2.2-24922

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 950
  • -Ontvangen: 5170
  • Berichten: 30.766
  • Synology is awesome.
    • Synology Support
Re: MariaDB 10 failed to run the package service
« Reactie #13 Gepost op: 22 april 2019, 15:41:11 »
Heb net even MariaDB geïnstalleerd, geen probleem, start gewoon op.

Bestaat /run/mysqld/mysqld10.sock wel ?
Veel mensen weten veel, maar niemand weet alles.


CS406     2 x HDS721075KLA330 DSM 2.0-0731       [ARCHIEF OPSLAG]
          ST3750640AS HD753LJ
DS107+    HDS722020ALA330     DSM 3.1-1639       [ARCHIEF OPSLAG]
DS111     WD40EZRZ            DSM 6.1.7-15284-3  [ARCHIEF OPSLAG]
DS411slim Wisselende HD's     DSM 6.2.1-23824-1  [SPEELTJE]
DS411+II  4 x HDS724040ALE640 DSM 6.1.7-15284-3  [PROD]
DS413j    4 x WD20EARX        DSM 6.1.7-15284-3  [BACKUP]
DS716+II  2 x DT01ACA050      DSM 6.2.2-24922    [TEST]
RT2600ac                      SRM 1.2.2-7915     [PROD]
MR2200ac                      SRM 1.2.2-7915     [PROD]

Offline RobertAthome

  • Bedankjes
  • -Gegeven: 3
  • -Ontvangen: 2
  • Berichten: 29
Re: MariaDB 10 failed to run the package service
« Reactie #14 Gepost op: 22 april 2019, 15:53:33 »
Nope deze is er niet.

Deze zou gemaakt moeten worden bij starten...
  • Mijn Synology: DS1515+
  • HDD's: 5x WD RED 3TB
  • Extra's: 6GB, DSM6.2.2-24922
DS411J, 2x Sam. 2TB HD204UI, 128MB, DSM6.2.2-24922


 

Package Center - MyDS Center

Gestart door Matr1xBoard Synology DSM 5.1 en eerder

Reacties: 9
Gelezen: 6955
Laatste bericht 06 maart 2013, 21:43:15
door Vinoglobe
package recovery na blue led recovery...

Gestart door CartaphilusBoard Wordpress package

Reacties: 2
Gelezen: 1528
Laatste bericht 17 maart 2017, 22:24:21
door Cartaphilus
Nieuwe Mailstation package MailStation-20100407-018

Gestart door wtfBoard Mail Station

Reacties: 0
Gelezen: 4120
Laatste bericht 14 april 2010, 06:27:42
door wtf
VERPLAATST: package recovery na blue led recovery...

Gestart door BirdyBoard Synology DSM 6.1

Reacties: 0
Gelezen: 866
Laatste bericht 08 maart 2017, 08:19:44
door Birdy
Zarafa geen "Officiële Package"?

Gestart door JosFBoard Vragen en opmerkingen OVER het forum

Reacties: 2
Gelezen: 2324
Laatste bericht 11 september 2012, 21:52:09
door JosF
Synology-Forum.nl is een Nederlands gebruikersforum en staat volledig los van het merk Synology. Lees onze privacyverklaring.