Auteur Topic: krijg SABnzbd niet opgestart met de snelkoppeling  (gelezen 6362 keer)

Offline Gil

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 1
  • Berichten: 8
Re: krijg SABnzbd niet opgestart met de snelkoppeling
« Reactie #15 Gepost op: 01 december 2014, 22:51:27 »
oké bedankt...laat maar iets weten als je het gevonden hebt. ;)
  • Mijn Synology: DS212+

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 1119
  • -Ontvangen: 6697
  • Berichten: 39.148
  • Synology is awesome.
    • RAID = BACKUP?
Re: krijg SABnzbd niet opgestart met de snelkoppeling
« Reactie #16 Gepost op: 01 december 2014, 23:05:58 »
Dat is snel, in feite heb ik de short gevonden in /usr/syno/synoman/webman/3rdparty/sabnzbd/config:

{
    ".url": {
        "com.synocommunity.packages.sabnzbd": {
            "title": "SABnzbd",
            "desc": "SABnzbd Web UI",
            "icon": "images/sabnzbd-{0}.png",
            "type": "url",
            "url": "3rdparty/sabnzbd/sabnzbd.cgi",
            "allUsers": true,
            "grantPrivilege": "local"
        }
    }
}

En die is niet gewijzigd (kan ik zien aan de datum van de file) dus, loopt er intern iets niet meer goed.

En deze "url": "3rdparty/sabnzbd/sabnzbd.cgi" wordt dus niet gevonden, eigenlijk dus:
"/usr/syno/synoman/webman/3rdparty/sabnzbd/sabnzbd.cgi" (denk ik), maar ik ben geen WEBmannetje.

Dus, NU de oplossing nog, wie o wie ?  :lol:

(ik blijf proberen, maar vanavond niet meer)

Workaround is dus een short maken op je PC/Browser/Favorieten naar http://<IP>:8080 en niet starten via Hoofdmenu/Shortcut.


CS406     DSM 2.0-0731
DS107+    DSM 3.1-1639
DS107+    DSM 3.1-1639
DS508     DSM 4.0-2265
DS111     DSM 6.1.7-15284-3
DS411slim DSM 6.2.4-25556
DS411+II  DSM 6.2.4-25556-2
DS413J    DSM 6.2.3-25426-2
DS1515+   DSM 6.2.4-25556
DS716+II  DSM 6.2.4-25556
DS918+    DSM 6.2.4-25556-2
DS220+    DSM 6.2.4-25556-2
-----VMM  DSM 7.0.1-42218
RT2600ac  SRM 1.2.5-8227-2
MR2200ac  SRM 1.2.5-8227-2

Martijn85

  • Gast
Re: krijg SABnzbd niet opgestart met de snelkoppeling
« Reactie #17 Gepost op: 01 december 2014, 23:20:53 »
Je bent in de buurt, het gaat om dit bestand die in de snelkoppeling wordt geopend: "/usr/local/sabnzbd/app/sabnzbd.cgi"

Kan iets afwijken omdat ik zelf geen SABnzbd gebruiker maar ik heb deze ook gemaakt voor mijn eigen pakketten.

Het gaat om een CGI script die de config van SABnzbd uitleest zodat die altijd de juist poort opent, ook als deze wordt gewijzigd.

Ik zelf gebruik geen SABnzbd dus ik kan dit niet testen, bij mij werken de overige pakketten nog wel via de snelkoppeling. SickBeard etc. maken hier namelijk ook gebruik van. Ik zou even een issue aanmaken bij Synocommunity. Volgens mij wordt er bij SABnzbd ook gecontroleerd of SABnzbd https gebruikt. Misschien dat het daar nu ergens fout gaat met het uitlezen van de config.

Offline Wim Maassluis

  • Bedankjes
  • -Gegeven: 10
  • -Ontvangen: 0
  • Berichten: 39
Re: krijg SABnzbd niet opgestart met de snelkoppeling
« Reactie #18 Gepost op: 01 december 2014, 23:22:25 »
Zelfde Probleem, maar ook nog niet op kunnen lossen.
  • Mijn Synology: DS112+
  • HDD's: HUA721010KLA330

Offline reempje

  • Bedankjes
  • -Gegeven: 19
  • -Ontvangen: 1
  • Berichten: 56
Re: krijg SABnzbd niet opgestart met de snelkoppeling
« Reactie #19 Gepost op: 05 december 2014, 12:45:01 »
Dit zelfde probleem heb ik ook al gemeld op 15 nov. Veel views op dit item gehad maar geen reacties.
Nu blijkt dat ik dus niet de enige ben die tegen dit probleem aangelopen was.
Jammer dat er nog geen oplossing is. Ik gebruik een shortcut in mijn browser (http://ipadres:8080)
DS1515+   5xST8000VN0022
DS418       2xST6000VN033, 2xST4000VN008

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 1119
  • -Ontvangen: 6697
  • Berichten: 39.148
  • Synology is awesome.
    • RAID = BACKUP?
Re: krijg SABnzbd niet opgestart met de snelkoppeling
« Reactie #20 Gepost op: 05 december 2014, 14:11:43 »
Nog geen oplossing, klopt echter, ik vind het eigenlijk heel normaal dat je gewoon via je browser (IE/Chrome....) SABnzbd of NZBGet te starten.

Waarom eerst naar je NAS, aanloggen om vervolgens via een icoontje te starten waarna een nieuwe browser sessie of tab wordt gestart met het programma ?
Merkwaardige omweg.  ;)


CS406     DSM 2.0-0731
DS107+    DSM 3.1-1639
DS107+    DSM 3.1-1639
DS508     DSM 4.0-2265
DS111     DSM 6.1.7-15284-3
DS411slim DSM 6.2.4-25556
DS411+II  DSM 6.2.4-25556-2
DS413J    DSM 6.2.3-25426-2
DS1515+   DSM 6.2.4-25556
DS716+II  DSM 6.2.4-25556
DS918+    DSM 6.2.4-25556-2
DS220+    DSM 6.2.4-25556-2
-----VMM  DSM 7.0.1-42218
RT2600ac  SRM 1.2.5-8227-2
MR2200ac  SRM 1.2.5-8227-2

Ben(V)

  • Gast
Re: krijg SABnzbd niet opgestart met de snelkoppeling
« Reactie #21 Gepost op: 05 december 2014, 14:44:47 »
Je kunt met dezelfde link een shortcut in je browser op je pc maken. Daar hoef je helemaal niet voor in je NAS in te loggen.
Dus http://192.168.0.xxx:5000/webman/3rdparty/sabnzbd/sabnzbd.cgi in je browser werkt ook.

Het voordeel van die .cgi bestandjes is dat die de config bestandjes van je applicatie (in dit geval SABnzb) uitlezen.
Als je dus je poort wijzigt in je app hoef je de link niet aan te passen.

Dat het niet meer werkt na een update naar DSM 5.1 zal wel iets met rechten te maken hebben.
Ik heb zelf geen SABnzb dus kan het niet nakijken.

Offline reempje

  • Bedankjes
  • -Gegeven: 19
  • -Ontvangen: 1
  • Berichten: 56
Re: krijg SABnzbd niet opgestart met de snelkoppeling
« Reactie #22 Gepost op: 05 december 2014, 18:43:04 »
Birdy schreef: [Waarom eerst naar je NAS, aanloggen om vervolgens via een icoontje te starten waarna een nieuwe browser sessie of tab wordt gestart met het programma.]

Komt misschien door mijn gebruik van de NAS, ik log vaak in op de nas en blijf dan ingelogt staan. Ik werk veel met Filestation om mijn videos te beheren. Af en toe wil ik dan een nieuwe serie toevoegen in de rss van SAB. Gemakshalve klik ik dan direkt op de link in DSM.
DS1515+   5xST8000VN0022
DS418       2xST6000VN033, 2xST4000VN008

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 1119
  • -Ontvangen: 6697
  • Berichten: 39.148
  • Synology is awesome.
    • RAID = BACKUP?
Re: krijg SABnzbd niet opgestart met de snelkoppeling
« Reactie #23 Gepost op: 05 december 2014, 20:28:42 »
In m'n browser heb ik ze ook bij de hand (NZBGet dan)  ;)

12991-0


CS406     DSM 2.0-0731
DS107+    DSM 3.1-1639
DS107+    DSM 3.1-1639
DS508     DSM 4.0-2265
DS111     DSM 6.1.7-15284-3
DS411slim DSM 6.2.4-25556
DS411+II  DSM 6.2.4-25556-2
DS413J    DSM 6.2.3-25426-2
DS1515+   DSM 6.2.4-25556
DS716+II  DSM 6.2.4-25556
DS918+    DSM 6.2.4-25556-2
DS220+    DSM 6.2.4-25556-2
-----VMM  DSM 7.0.1-42218
RT2600ac  SRM 1.2.5-8227-2
MR2200ac  SRM 1.2.5-8227-2

Ben(V)

  • Gast
Re: krijg SABnzbd niet opgestart met de snelkoppeling
« Reactie #24 Gepost op: 05 december 2014, 21:03:06 »
Heb Sabnzb even op m'n test nas geinstaleerd waar Dsm 5.1 op staat en inderdaad doet die shortcut het daar niet.
Op m'n Nas met Dsm 5.0 werkt dezelfde installatie wel goed.
Het vreemde is dat autosub eenzelfde soort constructie heeft met een .cgi bestandje en die werkt wel.
Zag wel dat er andere rechten op die bestandjes bij Sabnzb staan, maar openzetten van die rechten helpt niet.

Ik kom er niet uit dus ik zou aanraden om een issue aan te maken op de github van de synocommunity.

Ben(V)

  • Gast
Re: krijg SABnzbd niet opgestart met de snelkoppeling
« Reactie #25 Gepost op: 08 december 2014, 15:30:00 »
Heb even uitgezocht wat het probleem is.
Dat http://192.168.0.xxx:5000/webman/3rdparty/sabnzbd/sabnzbd.cgi bestandje gebruikt een python module genaamd "configobj" en die kan hij op mijn DSM 5.1 NAS niet vinden.
Op mijn DSM 5.0 geeft dat geen probleem.
Of die module nu met SABnzbd of met Python mee moet komen weet ik niet maar de oplossing was, hem zelf even te installeren.

Je kun die module hier downloaden:
https://pypi.python.org/pypi/configobj/

Zet hem ergens neer en pak hem uit.
Ga met een command prompt naar die locatie en geeft het volgende commando:
Citaat
/volume1/@appstore/python/bin/python2 setup.py install

Heb een issue aangemaakt bij de SynoCommunity zie:
https://github.com/SynoCommunity/spksrc/issues/1379


 

Hoe krijg ik mijn films van de Ziggo Humax 5200c naar mijn DS1010+?

Gestart door ATOWAPaulBoard FTP, NFS and Samba Server

Reacties: 27
Gelezen: 16565
Laatste bericht 21 oktober 2013, 16:46:21
door Briolet
Krijg geen gegevens binnen in roundcube..?

Gestart door richard5000Board Mail Station

Reacties: 0
Gelezen: 1245
Laatste bericht 21 juli 2012, 02:07:20
door richard5000
Na upload phpBB3 (full van phpBB.nl) krijg ik bij install poging '404 fout'

Gestart door SynologyNasUserBoard Overige 3rd party packages

Reacties: 7
Gelezen: 556
Laatste bericht 31 maart 2021, 00:44:39
door SynologyNasUser
Krijg de Foscam FI8904 draadloos

Gestart door frixelBoard Surveillance Station

Reacties: 16
Gelezen: 6099
Laatste bericht 16 mei 2013, 07:28:02
door frixel
Hoe krijg ik seeden aan de praat?

Gestart door stefimkeBoard Download Station

Reacties: 3
Gelezen: 3872
Laatste bericht 28 november 2012, 23:24:06
door joostdevries