Auteur Topic: SickBeard post processing probleem  (gelezen 20399 keer)

Offline Matr1x

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 235
  • -Ontvangen: 751
  • Berichten: 4.914
Re: SickBeard post processing probleem
« Reactie #15 Gepost op: 26 september 2011, 18:54:05 »
Zowel SickBeard als Headphones zijn hele mooie programma's voor op de DiskStation. Van CouchPotato had ik iets meer van verwacht, maar wie weet komt dat nog wel een keer goed in een latere versie.
  • Mijn Synology: DS218Play
  • HDD's: 2x WD40EFRX
  • Extra's: RT1900ac

Offline RLX

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 60
Re: SickBeard post processing probleem
« Reactie #16 Gepost op: 01 oktober 2011, 22:52:30 »
Heb inmiddels alles opnieuw ge├»nstalleerd en ingesteld. Het werkt nu  :D .
Ik weet ook al wat ik fout heb gedaan. Ik had zowel voor SAB als SickBeard hetzelfde adres opgevoerd als de plek waar hij het in eerste instantie gaat downloaden en daarna naartoe verplaatsen. Dat gaat natuurlijk niet goed.
Nogmaals bedankt voor de hulp!

Offline Joosts

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 3
Re: SickBeard post processing probleem
« Reactie #17 Gepost op: 01 november 2011, 23:22:59 »
Ook ik heb SB geinstalleerd conform instructie.
Aanmaken van mappen is niet mogelijk, ik ben er nu achter waarom. De SB user bestaat niet meer. Dit na een update.
Ik heb geprobeerd de user handmatig aan te maken maar dit staat DSM3.2 niet toe. Is er een andere oplossing dan alles deinstalleren en weer installeren?

Zo nee, kan ik configuratieinstellingen behouden zodat ik dit kan hergebruiken?

Bij voorbaat dank voor jullie reactie.

Offline Matr1x

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 235
  • -Ontvangen: 751
  • Berichten: 4.914
Re: SickBeard post processing probleem
« Reactie #18 Gepost op: 02 november 2011, 08:29:38 »
Als je SickBeard verwijderd (uninstall) ben je ook de instellingen kwijt. Ik heb die onlangs wel veiliggesteld, maar dit valt niet zomaar terug te zetten. Alleen de config.ini kun je terugzetten, maar dan moet je wel weer je hele verzameling opnieuw opbouwen. Ook dit gaat redelijk eenvoudig met Add Existing Shows.

Ik zie ook dat na installatie van 3.1.1 de gebruiker sickbeard er niet meer is. Toch werkt Sickbeard hier gewoon en wordt de eigenaar van de gedownloade bestanden niet aangepast. Deze blijft dus sabnzbd. Dat is nieuwe. Van de metabestanden die SickBeard aanmaakt is de gebruiker sickbeard wel de eigenaar. Vreemd want die gebruiker bestaat dus niet meer.

Net even een nieuwe serie toegevoegd en die komt er dus niet bij. Waarschijnlijk omdat een nieuwe map niet aangemaakt kan worden. Probeerde net de gebruiker sickbeard aan te maken, maar DSM geeft een foutmelding. Misschien wel omdat er nog bestanden zijn waar dit account eigenaar van is.

Ik ga dit na werktijd wel even verder uitzoeken, want SickBeard moet wel goed blijven werken!
  • Mijn Synology: DS218Play
  • HDD's: 2x WD40EFRX
  • Extra's: RT1900ac

Offline Matr1x

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 235
  • -Ontvangen: 751
  • Berichten: 4.914
Re: SickBeard post processing probleem
« Reactie #19 Gepost op: 02 november 2011, 19:15:37 »
Even gekeken en gebruikersaccount sickbeard bestaat dus wel nog gewoon, maar is niet meer zichtbaar in DSM:
Citaat
DiskStation> awk -F":" '{ print "username: " $1 "ttuid:" $3 }' /etc/passwd
username: root          uid:0
username: lp            uid:4
username: ftp           uid:21
username: anonymous             uid:21
username: smmsp         uid:25
username: postfix               uid:125
username: dovecot               uid:143
username: spamfilter            uid:783
username: couchpotato           uid:1000
username: headphones            uid:1002
username: nobody                uid:1023
username: admin         uid:1024
username: guest         uid:1025
username: dm800         uid:1032
username: xbox          uid:1033
username: sabnzbd               uid:1034
username: boxee         uid:1035
username: sickbeard             uid:1001
DiskStation>

Heb wel even de persoonlijk accounts uit het lijstje gehaald. Ga later nog wel wat meer testen. Nu eerst even sporten  8)
  • Mijn Synology: DS218Play
  • HDD's: 2x WD40EFRX
  • Extra's: RT1900ac

Offline Matr1x

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 235
  • -Ontvangen: 751
  • Berichten: 4.914
Re: SickBeard post processing probleem
« Reactie #20 Gepost op: 02 november 2011, 20:27:33 »
Even installatiescript bekeken en gebruikeraccount sickbeard wordt inderdaad verwijderd :roll:


   36  +    # Remove the DSM user
   37  +    if ${SYNOUSER} --enum local | grep "^${PACKAGE}$" >/dev/null
   38  +    then
   39  +        # Keep the existing uid
   40  +        uid=`grep ${PACKAGE} /etc/passwd | cut -d: -f3`
   41  +        ${SYNOUSER} --del ${PACKAGE} 2> /dev/null
   42  +        UID_PARAM="-u ${uid}"
   43  +    fi

  • Mijn Synology: DS218Play
  • HDD's: 2x WD40EFRX
  • Extra's: RT1900ac

Offline Joosts

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 3
Re: SickBeard post processing probleem
« Reactie #21 Gepost op: 04 november 2011, 10:03:44 »
Matrix, bedankt voor het uitzoeken. Ik zie inderdaad ook een user 1021 staan.

Wordt de user bij herinstallatie van 3.1.1 weer opnieuw aangemaakt? Of lukt ook de install dat niet net als een handmatige toevoeging via dsm.

Thanks

Offline Matr1x

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 235
  • -Ontvangen: 751
  • Berichten: 4.914
Re: SickBeard post processing probleem
« Reactie #22 Gepost op: 04 november 2011, 15:21:53 »
Nee er wordt geen nieuwe DSM gebruiker aangemaakt in versie 3.1.1. Ik weet niet of dit een fout in het installatiescript is of dat het niet meer nodig is. Ik verwacht dat het een fout is want nu is sickbeard nog steeds eigenaar van bepaalde mappen en bestanden. Helaas kun je zelf de gebruiker niet meer aanmaken, tenzij hier een truuk in Linux.
  • Mijn Synology: DS218Play
  • HDD's: 2x WD40EFRX
  • Extra's: RT1900ac

Offline Joosts

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 3
Re: SickBeard post processing probleem
« Reactie #23 Gepost op: 04 november 2011, 15:27:16 »
Ok, dan ga ik terug naar v3.1.
Heb trouwens exact hetzelfde probleem in CP 3.1.1. Bij de update van 3.1 naar 3.1.1 is de CP user ook verdwenen.

Offline Matr1x

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 235
  • -Ontvangen: 751
  • Berichten: 4.914
Re: SickBeard post processing probleem
« Reactie #24 Gepost op: 04 november 2011, 16:24:28 »
Zit nog even te kijken, maar in het start script van de pakketten staat nog wel heel duidelijk dat het eigen account gebruikt wordt (sickbeard, headphones, couchpotato). Je kunt dat wel veranderen, maar kennelijk is dus echt het installatiescript fout.

PACKAGE="sickbeard"
DNAME="Sick Beard"
<knip>
RUNAS="${PACKAGE}"
  • Mijn Synology: DS218Play
  • HDD's: 2x WD40EFRX
  • Extra's: RT1900ac

Offline Matr1x

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 235
  • -Ontvangen: 751
  • Berichten: 4.914
Re: SickBeard post processing probleem
« Reactie #25 Gepost op: 06 november 2011, 20:49:03 »
Ik had /usr/local/etc/rc.d/SickBeard.sh even aangepast en RUNAS="admin" gebruikt, maar zodra je het pakket weer start wordt deze file weer teruggezet lijkt wel. Dan staat er namelijk weer gewoon RUNAS="${PACKAGE}".

Ik denk dat dit dus alleen op te lossen is door de gebruiker account sickbeard weer terug te zetten. Nog geen idee hoe ik dit moet doen, want via DSM krijg je een foutmelding (omdat ID al bestaat).
  • Mijn Synology: DS218Play
  • HDD's: 2x WD40EFRX
  • Extra's: RT1900ac

Offline Matr1x

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 235
  • -Ontvangen: 751
  • Berichten: 4.914
Re: SickBeard post processing probleem
« Reactie #26 Gepost op: 10 november 2011, 22:19:04 »
Heb denk ik het probleem al gevonden van de installatie scripts. Er staat namelijk:

# Create the service user if needed    
if grep "^${PACKAGE}:" /etc/passwd >/dev/null    
then        
true    
else        
adduser -h ${VAR_DIR} -g "${DNAME} User" -G users -D -H ${UID_PARAM} -s /bin/sh ${PACKAGE}    
fi
En op DiskStation bestaat het commando adduser helemaal niet, tenzij je Bootstrap (IPKG) geinstalleerd hebt. Dat verklaard wel waarom dit probleem niet gemeld wordt, want ik denk dat veel mensen dit wel gewoon geinstalleerd hebben.

Ik heb een poging gewaagd met synouser --add, maar dat werkt dus ook niet. Iemand nog een suggestie om een gebruiker aan te maken, die al voorkomt?
  • Mijn Synology: DS218Play
  • HDD's: 2x WD40EFRX
  • Extra's: RT1900ac

Offline Matr1x

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 235
  • -Ontvangen: 751
  • Berichten: 4.914
Re: SickBeard post processing probleem
« Reactie #27 Gepost op: 12 november 2011, 00:26:45 »
Duh... heb een reactie van Zebulon gehad (the one and only) en de accounts zijn er dus nog wel degelijk alleen verborgen. Dat is met opzet gedaan om te voorkomen dat gebruikers ze in DSM gaan aanpassen of verwijderen. Daar zit wat in natuurlijk, alleen kun je nu niet meer zelf bijvoorbeeld sickbeard of headphones owner maken van een map of bestand. Althans niet in DSM, maar wel met telnet.

Ik heb mijn problemen kunnen oplossen door de mappen even terug te zetten naar de download folder en ze vervolgens door sickbeard en headphones opnieuw te laten processen. Dan worden er dus nieuwe mappen aangemaakt op de bestemming (music en video) met de juiste owner (sickbeard of headphones) en de juiste rechten. Nu kunnen er ook zonder problemen nieuwe mappen en bestanden bijgezet worden.
  • Mijn Synology: DS218Play
  • HDD's: 2x WD40EFRX
  • Extra's: RT1900ac

Offline Nazgul

  • MVP
  • *
  • Bedankjes
  • -Gegeven: 25
  • -Ontvangen: 41
  • Berichten: 298
Re: SickBeard post processing probleem
« Reactie #28 Gepost op: 26 december 2011, 17:23:59 »
Citaat van: "RLX"
Zal ik doen. SAb werkte goed, ook met de categorie├źn. Daarom vind ik het ook zo vreemd. Heb volgens mij precies de aanwijzigen gevolgd zoals beschreven. Maar goed, ik ga het weer proberen. Bedankt voor het moed inpraten  :wink:

We zijn inmiddels enkele maanden verder en ik ben nieuwsgierig of het nu dan bij je werkt RLX.
Ik denk erover na om Sickbeard te gaan installeren. In januari 2012 starten een 3tal voor mij interessante series en dan zou het mooi zijn dat ze elke week kant en klaar voor me staan om ze te bekijken. Echter: ik lees dat dat met het zoeken naar ondertitelingen nog een hele toer gaat worden. Of is er inmiddels een verbeterde versie van Sickbeard uit? Ik denk dat ik met de installatiehandleiding een heel eind kom maar ik hoor graag nog tips, truuks, en laatste ervaringen, vandaar.
  • Mijn Synology: DS 1019+
  • HDD's: 5 x SEAGATE 4TB
  • Extra's: DS414 (Back Up)

DS1019+  DSM 7.0-41890  |
DS414  DSM 6.2.3-25426 Update 2
Netgear R8500| NVIDEA Shield|

Offline Robert Koopman

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 247
  • -Ontvangen: 1769
  • Berichten: 10.860
    • http://www.dwvbb.nl
Re: SickBeard post processing probleem
« Reactie #29 Gepost op: 26 december 2011, 17:36:33 »
Ondertitels een hele tour als je drie series volgt??
Ik volg er over de 100 en met bierdopje.com stelt het echt niets voor.
DS712+    : 2*WD30EFRX DSM 6.2.1-24922 RAID-1
DS1812+  : 8*WD30EFRX DSM 6.2.1-24922 RAID-5
DS411+II : 4*WD30EZRX DSM 6.2.1-24922 SHR


 

Sickbeard custom (Sickrage) op DSM 6.0.2-8451 Update 1

Gestart door wvkregBoard SickBeard

Reacties: 2
Gelezen: 6919
Laatste bericht 06 oktober 2016, 23:02:41
door neo_atomic
Working Forks - Sickbeard & Sickrage

Gestart door rTnBoard SickBeard

Reacties: 109
Gelezen: 61015
Laatste bericht 03 november 2018, 16:56:41
door Birdy
Sabnzb / sickbeard / spotweb invalid nzb

Gestart door killerschaapBoard Download mods

Reacties: 1
Gelezen: 1751
Laatste bericht 24 maart 2014, 12:42:36
door Birdy
SickBeard + Trakt = Top combinatie

Gestart door Matr1xBoard SickBeard

Reacties: 18
Gelezen: 8467
Laatste bericht 24 maart 2014, 20:00:45
door Matr1x
sickbeard twitter vermelding aanpassing

Gestart door buzzkeBoard SickBeard

Reacties: 5
Gelezen: 1993
Laatste bericht 20 november 2012, 18:57:57
door buzzke