Auteur Topic: phpbb, na upgrade DSM 5 vervelende foutmeldingen phpBB board  (gelezen 4330 keer)

Offline SynologyNasUser

  • Bedankjes
  • -Gegeven: 12
  • -Ontvangen: 4
  • Berichten: 95
  • Aanname is vaak de oorzaak van veel ellende.
    • mkservices.nl
phpbb, na upgrade DSM 5 vervelende foutmeldingen phpBB board
« Gepost op: 18 maart 2014, 21:28:19 »
Na de upgrade van DSM naar versie 5 kreeg ik tijdens het laden van het registratie formulier in phpBB meteen een aantal foutmeldingen met captcha.
De captcha afbeelding verschijnt ook niet, zodoende kan ik de aanmelding dan ook niet afronden.
Onderstaand de omschrijving van de fouten bij het laden van de pagina.

"Strict Standards: Non-static method phpbb_captcha_factory::get_instance() should not be called statically, assuming $this from incompatible context in /volume1/web/phpbb/includes/ucp/ucp_register.php on line 164 Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method phpbb_captcha_gd_wave::get_instance() should not be called statically in /volume1/web/phpbb/includes/captcha/captcha_factory.php on line 38 Strict Standards: Non-static method utf_normalizer::nfc() should not be called statically in /volume1/web/phpbb/includes/utf/utf_tools.php on line 1781"

Als ik met Filezilla (ftp client) inlog in de back-end, kan ik de genoemde bestanden vinden, maar verder dan dit kom ik dan niet.
Wie herkent dit en kan mij hiermee helpen?
  • Mijn Synology: ds218+
  • HDD's: 2 x 2TB
ICT onderwijs ondersteuner

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 1119
  • -Ontvangen: 6697
  • Berichten: 39.148
  • Synology is awesome.
    • RAID = BACKUP?
Re: phpbb, na upgrade DSM 5 vervelende foutmeldingen phpBB board
« Reactie #1 Gepost op: 18 maart 2014, 22:54:48 »
Ik heb er geen verstand van maar Google even, kreeg nogal wat hits op:
"strict standards call_user_func() expects parameter 1 to be a valid callback non-static method"
My two cents  ;)


CS406     DSM 2.0-0731
DS107+    DSM 3.1-1639
DS107+    DSM 3.1-1639
DS508     DSM 4.0-2265
DS111     DSM 6.1.7-15284-3
DS411slim DSM 6.2.4-25556
DS411+II  DSM 6.2.4-25556-2
DS413J    DSM 6.2.3-25426-2
DS1515+   DSM 6.2.4-25556
DS716+II  DSM 6.2.4-25556
DS918+    DSM 6.2.4-25556-2
DS220+    DSM 6.2.4-25556-2
-----VMM  DSM 7.0.1-42218
RT2600ac  SRM 1.2.5-8227-2
MR2200ac  SRM 1.2.5-8227-2

Offline SynologyNasUser

  • Bedankjes
  • -Gegeven: 12
  • -Ontvangen: 4
  • Berichten: 95
  • Aanname is vaak de oorzaak van veel ellende.
    • mkservices.nl
Re: phpbb, na upgrade DSM 5 vervelende foutmeldingen phpBB board
« Reactie #2 Gepost op: 18 maart 2014, 23:21:58 »
Bedankt Birdy, voor je reactie,
Ook ik heb gegoogled, maar nog geen passende oplossing gevonden.
Helaas....
  • Mijn Synology: ds218+
  • HDD's: 2 x 2TB
ICT onderwijs ondersteuner

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 1119
  • -Ontvangen: 6697
  • Berichten: 39.148
  • Synology is awesome.
    • RAID = BACKUP?
Re: phpbb, na upgrade DSM 5 vervelende foutmeldingen phpBB board
« Reactie #3 Gepost op: 18 maart 2014, 23:27:01 »
Ok...was te proberen  ;)


CS406     DSM 2.0-0731
DS107+    DSM 3.1-1639
DS107+    DSM 3.1-1639
DS508     DSM 4.0-2265
DS111     DSM 6.1.7-15284-3
DS411slim DSM 6.2.4-25556
DS411+II  DSM 6.2.4-25556-2
DS413J    DSM 6.2.3-25426-2
DS1515+   DSM 6.2.4-25556
DS716+II  DSM 6.2.4-25556
DS918+    DSM 6.2.4-25556-2
DS220+    DSM 6.2.4-25556-2
-----VMM  DSM 7.0.1-42218
RT2600ac  SRM 1.2.5-8227-2
MR2200ac  SRM 1.2.5-8227-2

Offline wolfpins

  • Bedankjes
  • -Gegeven: 5
  • -Ontvangen: 2
  • Berichten: 77
Re: phpbb, na upgrade DSM 5 vervelende foutmeldingen phpBB board
« Reactie #4 Gepost op: 19 maart 2014, 06:37:39 »
Heeft waarschijnlijk met de nieuwe database te maken
  • Mijn Synology: ds213j
  • HDD's: WD Red 2,0TB SATA6 I
DSM 6.1-15047 Update 1

Offline maslov

  • Bedankjes
  • -Gegeven: 4
  • -Ontvangen: 6
  • Berichten: 69
Re: phpbb, na upgrade DSM 5 vervelende foutmeldingen phpBB board
« Reactie #5 Gepost op: 19 maart 2014, 10:56:39 »
Volgens mij is dit je probleem:

The PHP version has been updated to 5.5. Please check the compatibility of your PHP-based web apps with php 5.5. The details can be found at Migrating from PHP 5.3.x to PHP 5.4.x and Migrating from PHP 5.4.x to PHP 5.5.x.

Je kunt dit (met de bovenstaande links) vinden in de release-notes van DSM 5 bij het hoofdstukje Web Station.

Ik draai een phpBB3-forum bij een externe provider en die is begin deze week naar PHP 5.4 gegaan en ik moest daarom mijn forumsoftware bijwerken tot de laatste versie anders zou ik ook gelijksoortige meldingen krijgen. Je zult dus ook je phpBB-board software moeten aanpassen!

Succes!
DS413  DS211+  RT1900AC

Offline SynologyNasUser

  • Bedankjes
  • -Gegeven: 12
  • -Ontvangen: 4
  • Berichten: 95
  • Aanname is vaak de oorzaak van veel ellende.
    • mkservices.nl
Re: phpbb, na upgrade DSM 5 vervelende foutmeldingen phpBB board
« Reactie #6 Gepost op: 19 maart 2014, 13:23:55 »
Volgens mij is dit je probleem:

The PHP version has been updated to 5.5. Please check the compatibility of your PHP-based web apps with php 5.5. The details can be found at Migrating from PHP 5.3.x to PHP 5.4.x and Migrating from PHP 5.4.x to PHP 5.5.x.

Je kunt dit (met de bovenstaande links) vinden in de release-notes van DSM 5 bij het hoofdstukje Web Station.

Ik draai een phpBB3-forum bij een externe provider en die is begin deze week naar PHP 5.4 gegaan en ik moest daarom mijn forumsoftware bijwerken tot de laatste versie anders zou ik ook gelijksoortige meldingen krijgen. Je zult dus ook je phpBB-board software moeten aanpassen!

Succes!

Kijk, nu komen we ergens......
Dank maslov, dit is informatie waar ik doelgericht mee kan zoeken.
Bij mij draait ook phpbb3 en draait op de NAS.
Ik ga nu op zoek naar compatibiliteit/update of upgrade.

Eerst backup gemaakt van de phpbb database.
MySql_upgrade.php gekopieerd en gedraaid, maar met de output kan ik niet verder.
De output zit vol met waarschuwingen, maar Captcha fouten kom ik er niet in tegen.
Hoe moet ik de output gebruiken?
Als er geen andere oplossing is, kan ik misschien beter de hele installatie opnieuw uitvoeren en daarna backup terugplaatsen.

  • Mijn Synology: ds218+
  • HDD's: 2 x 2TB
ICT onderwijs ondersteuner


 

Na upload phpBB3 (full van phpBB.nl) krijg ik bij install poging '404 fout'

Gestart door SynologyNasUserBoard Overige 3rd party packages

Reacties: 7
Gelezen: 556
Laatste bericht 31 maart 2021, 00:44:39
door SynologyNasUser
Spotweb installatie naast phpbb forum

Gestart door ArgonBoard Spotweb

Reacties: 2
Gelezen: 2628
Laatste bericht 07 april 2011, 20:36:05
door caveman
Huidig phpbb forum behouden bij overstap op DSM7

Gestart door CKBoard Synology DSM BETA versies

Reacties: 4
Gelezen: 509
Laatste bericht 03 februari 2021, 13:55:01
door CK
[PHPBB] Forum logo

Gestart door MescalinoBoard Overige 3rd party packages

Reacties: 1
Gelezen: 925
Laatste bericht 10 mei 2015, 20:12:27
door Mescalino
phpBB installatie

Gestart door geertnBoard Web Station

Reacties: 2
Gelezen: 5393
Laatste bericht 25 april 2007, 09:30:55
door Björn