Auteur Topic: Kan geen Let's Encrypt certificaat creëeren.  (gelezen 764 keer)

Offline nuss

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 6
  • Brrrrttt!!
Kan geen Let's Encrypt certificaat creëeren.
« Gepost op: 16 januari 2019, 11:55:59 »
Dag iedereen,

Nadat ik mijn NAS een tijd lang zeer tevreden in gebruik heb gehad is zojuist mijn Let's Encrypt certificaat verlopen en heb ik dus moeite om netjes mijn NAS te bereiken en van de apps gebruik te maken.
Eerder heb ik al een geldig certificaat gemaakt (hoe precies is me niet bijgebleven) op mijn domein waarmee ik mijn DSM kon benaderen, maar het verlengen lukte ineens niet meer.

Nu krijg ik dus de volgende melding van DSM wanneer ik via Let's Encrypt een nieuw certificaat op mijn domein probeer te zetten:



Failed to connect to Let’s Encrypt. Please make sure the domain name is valid.


Ik heb het volgende gecontroleerd:
  • Poort 80 & 443 staan open
  • Wanneer ik naar mijndomein.nl ga kom ik uit bij mijn DSM, alleen met de melding dat het certificaat niet klopt.
Volgensmij zou dit het moeten zijn gezien de help-pagina's en tips op het internet, maar ik blijf de foutmelding maar krijgen.
Heeft iemand een idee wat ik hier mis?

Alvast bedankt!
  • Mijn Synology: DS218+

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 950
  • -Ontvangen: 5170
  • Berichten: 30.766
  • Synology is awesome.
    • Synology Support
Re: Kan geen Let's Encrypt certificaat creëeren.
« Reactie #1 Gepost op: 16 januari 2019, 13:00:18 »
Als poort 80 is forwarded, dan zou het certificaat automatisch verlengt moeten zijn.
Maar ik zie dat je een nieuwe probeert te maken echter, je krijgt geen contact met Let's Encrypt.

Heeft je NAS wel toegang naar het internet, kijk eens bij DSM update of je daar een error krijgt.
Veel mensen weten veel, maar niemand weet alles.


CS406     2 x HDS721075KLA330 DSM 2.0-0731       [ARCHIEF OPSLAG]
          ST3750640AS HD753LJ
DS107+    HDS722020ALA330     DSM 3.1-1639       [ARCHIEF OPSLAG]
DS111     WD40EZRZ            DSM 6.1.7-15284-3  [ARCHIEF OPSLAG]
DS411slim Wisselende HD's     DSM 6.2.1-23824-1  [SPEELTJE]
DS411+II  4 x HDS724040ALE640 DSM 6.1.7-15284-3  [PROD]
DS413j    4 x WD20EARX        DSM 6.1.7-15284-3  [BACKUP]
DS716+II  2 x DT01ACA050      DSM 6.2.2-24922    [TEST]
RT2600ac                      SRM 1.2.2-7915     [PROD]
MR2200ac                      SRM 1.2.2-7915     [PROD]

Offline nuss

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 6
  • Brrrrttt!!
Re: Kan geen Let's Encrypt certificaat creëeren.
« Reactie #2 Gepost op: 16 januari 2019, 13:11:36 »
Hi Birdy, Thx voor de reply!

Inderdaad, mijn poort 80 en 443 zijn forwarded, en met beiden kom ik uit op mijn DSM. Echter, toen ik het certificaat wilde verlengen kreeg ik dezelfde melding.

Ondertussen heb ik het oude certificaat op mijndomein.nl verwijderd, en een nieuwe op de Synology DDNS gezet (xxx.synology.me). Zo heb ik mijn spul nog bereikbaar.
Wanneer ik dan een nieuw certificaat aan maak krijg ik de melding in het bericht hiervoor.

De NAS heeft toegang tot het internet, met de apps krijg ik gewoon toegang tot mijn gegevens, en DSM update zegt het volgende:

  • Mijn Synology: DS218+

Offline nuss

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 6
  • Brrrrttt!!
Re: Kan geen Let's Encrypt certificaat creëeren.
« Reactie #3 Gepost op: 24 januari 2019, 12:51:08 »
Uiteindelijk gevonden bij Synoguide wat er miste.
Kennelijk stonden mijn instellingen bij Web Station's Virtual Host nog niet helemaal goed. Ik heb aanpassingen gemaakt zoals te zien in de link, en dit maakte het werkend voor mij. Ik kon hiermee een certificaat op mijn domein aanmaken, welke in orde was via SSL Labs.

Eindelijk weer netjes online!  8)
  • Mijn Synology: DS218+

Offline jelleruben

  • Bedankjes
  • -Gegeven: 18
  • -Ontvangen: 24
  • Berichten: 294
Re: Kan geen Let's Encrypt certificaat creëeren.
« Reactie #4 Gepost op: 01 april 2019, 11:54:59 »
Ik heb hetzelfde probleem eigelijk kan ook geen  Let's Encrypt certificaat aanmaken.
De poorten staan in de modem/router geforward.

Misschien een domme beginners vraag, bij het aanmaken, welke domein dien je
in te vullen? je eigen (xxxxx.nl) of die van synology?
  • Mijn Synology: DS213j
  • HDD's: 2 X 1TB

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 950
  • -Ontvangen: 5170
  • Berichten: 30.766
  • Synology is awesome.
    • Synology Support
Re: Kan geen Let's Encrypt certificaat creëeren.
« Reactie #5 Gepost op: 01 april 2019, 12:04:16 »
Als je een eigen domeinnaam hebt gekocht, dan gebruik je die, uiteraard.
Veel mensen weten veel, maar niemand weet alles.


CS406     2 x HDS721075KLA330 DSM 2.0-0731       [ARCHIEF OPSLAG]
          ST3750640AS HD753LJ
DS107+    HDS722020ALA330     DSM 3.1-1639       [ARCHIEF OPSLAG]
DS111     WD40EZRZ            DSM 6.1.7-15284-3  [ARCHIEF OPSLAG]
DS411slim Wisselende HD's     DSM 6.2.1-23824-1  [SPEELTJE]
DS411+II  4 x HDS724040ALE640 DSM 6.1.7-15284-3  [PROD]
DS413j    4 x WD20EARX        DSM 6.1.7-15284-3  [BACKUP]
DS716+II  2 x DT01ACA050      DSM 6.2.2-24922    [TEST]
RT2600ac                      SRM 1.2.2-7915     [PROD]
MR2200ac                      SRM 1.2.2-7915     [PROD]

Offline Briolet

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 103
  • -Ontvangen: 1604
  • Berichten: 10.456
Re: Kan geen Let's Encrypt certificaat creëeren.
« Reactie #6 Gepost op: 01 april 2019, 12:24:27 »
Of je zet ze er beide in.
  • Mijn Synology: DS415+
  • HDD's: 3x 3TB in SHR

Offline jelleruben

  • Bedankjes
  • -Gegeven: 18
  • -Ontvangen: 24
  • Berichten: 294
Re: Kan geen Let's Encrypt certificaat creëeren.
« Reactie #7 Gepost op: 01 april 2019, 12:50:46 »
Ja ik heb inderdaad een gekochte domein (zonder een hosting pakket). Echter als ik dus
deze invul. Dan krijg ik ook de melding

"Failed to connect to Let’s Encrypt. Please make sure the domain name is valid."

Ik heb ook gekeken naar de web station, echter zie ik daar (in mijn oog) niets vreemds aan.
  • Mijn Synology: DS213j
  • HDD's: 2 X 1TB

Offline nuss

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 6
  • Brrrrttt!!
Re: Kan geen Let's Encrypt certificaat creëeren.
« Reactie #8 Gepost op: 03 april 2019, 10:18:15 »
Bij het verlengen van mijn certificaat zojuist weer tegen hetzelfde probleem gelopen. Kennelijk had ik de vorige keer iets aan mijn web station aangepast waardoor het nu niet in 1 keer doorliep.

Onderstaande screenshot toont de settings van web station waarmee het mij lukte. @jelleruben , wellicht is dit ook het proberen waard voor jou?

Overigens ben ik hier ook nog een uitleg tegen gekomen over hoe je een certificaat kan toevoegen. Ook hier komt Web Station naar voren, wat ik vreemd vind, aangezien in de Synology guide er niet over wordt gesproken.

Succes!

  • Mijn Synology: DS218+

Offline jelleruben

  • Bedankjes
  • -Gegeven: 18
  • -Ontvangen: 24
  • Berichten: 294
Re: Kan geen Let's Encrypt certificaat creëeren.
« Reactie #9 Gepost op: 03 april 2019, 10:44:07 »
Heel erg bedankt voor de informatie. Ik zal het proberen als ik weer internet heb.

Offtopic Ziggo is weer eens bezig met onderhoud en ze zeggen wel tot dinsdag :x

Ontoptic  zal snel proberen, maar zeker bedankt.
  • Mijn Synology: DS213j
  • HDD's: 2 X 1TB

Offline nuss

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 6
  • Brrrrttt!!
Re: Kan geen Let's Encrypt certificaat creëeren.
« Reactie #10 Gepost op: 03 april 2019, 11:01:08 »
Als je overigens je NAS van buiten je eigen netwerk kan bereiken dan kan je het ook elders doen, via een andere provider die wel werkt  ;) Anders is het nog even wachten, of je NAS mee op stap nemen. Succes!
  • Mijn Synology: DS218+

Offline mr cable guy

  • Bedankjes
  • -Gegeven: 17
  • -Ontvangen: 0
  • Berichten: 35
Re: Kan geen Let's Encrypt certificaat creëeren.
« Reactie #11 Gepost op: 04 april 2019, 10:33:29 »
Ik sluit mij graag aan bij dit topic omdat het mij ook niet wil lukken.
Ben al een hele tijd bezig, maar kom er niet uit.

Ik had twee routers achter elkaar staan, dacht dat dit het probleem was, dus mijn eigen in bridge modus gezet.
Helaas niet geholpen.

Ik heb een Experiabox nu als router.
Deze helemaal terug gezet.
via :  https://forum.telfort.nl/internet-267/uitleg-port-forwarding-instellen-op-een-experiabox-v10-69379
de poorten 80 en 443 naar het vaste ip adres van de NAS gezet.
volgens https://www.yougetsignal.com/tools/open-ports/ staan de poorten open.

Helaas zelfde resultaat (ik heb alleen de Nederlandse versie : "Verbinding met Let's Encrypt is mislukt. Vergewis u ervan dat de domeinnaam geldig is. "

Ik heb toen maar (ik zit bij mijn domein) een hostingpakket genomen. Hierbij kan ik wel met mijn eigen domein doorlinken naar mijn NAS. Echter.... het is nog steeds geen geldig certificaat...

Ik heb het bovenstaande geprobeerd en aangepast in Virtuele host... maar dat doet bij mij ook niet.

De melding: vergewis dat de domeinnaam geldig is... geeft mij ook geen duidelijk beeld wat de fout nu is.
Ik ben eigenaar van het domein. Dat is het dus niet! maar wat wel.

Mijn NAS is te bereiken van buiten, via quickconnect en gewone externe toegang.

Uit baldadigheid heb ik een niet bestaand domeinnaam ingevuld (wel van mij maar xxxx1.nl) een 1 erbij. dan krijg ik een andere foutmelding. die dan weer suggereert dan mijn poort 80 niet open zou staan.  Ik begrijp het niet meer. Dus hoop ik dat iemand mij hier het licht kan laten zien!
alvast bedankt.
  • Mijn Synology: DS415+
  • HDD's: 3x wd60 & 1x wd80
Men hoeft niet iets goed te kunnen om iets goeds te kunnen doen.

Offline nuss

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 6
  • Brrrrttt!!
Re: Kan geen Let's Encrypt certificaat creëeren.
« Reactie #12 Gepost op: 09 april 2019, 14:36:35 »
Heren,

Ik heb ook echt dagen vanalles geprobeerd, maar uiteindelijk ben ik er gekomen door de settings van DNS en de poorten op de normale manier in te stellen, én Web Station in te richten als hierboven omschreven. Wat zijn jullie bevindingen bij het aanmaken van een dergelijke virtual host?

Ciao!
  • Mijn Synology: DS218+

Offline mr cable guy

  • Bedankjes
  • -Gegeven: 17
  • -Ontvangen: 0
  • Berichten: 35
Re: Kan geen Let's Encrypt certificaat creëeren.
« Reactie #13 Gepost op: 14 april 2019, 10:36:26 »
Beste Nuss,

Bedankt voor je reactie.
Helaas kom ik niet verder. Heel frustrerend, wat ik lees en doe, het werkt helaas niet.
Dus als iemand nog een goed idee of een oplossing heeft. Ik hoor het graag.

Alvast bedankt voor de reactie.
Groeten.
  • Mijn Synology: DS415+
  • HDD's: 3x wd60 & 1x wd80
Men hoeft niet iets goed te kunnen om iets goeds te kunnen doen.


 

Firewall uit media ok, firewall aan geen media (ACRyan)

Gestart door Daniel1974Board Media Server (UPNP/DLNA)

Reacties: 6
Gelezen: 7012
Laatste bericht 05 augustus 2012, 19:54:06
door TonVH
Geen internet via internet

Gestart door markcoolBoard WebDav

Reacties: 1
Gelezen: 3227
Laatste bericht 29 juli 2015, 00:51:40
door Hutje
RAID of geen RAID...

Gestart door dimBoard NAS hardware vragen

Reacties: 12
Gelezen: 5438
Laatste bericht 05 december 2015, 00:10:42
door bronan
Synology maakt contact met een vreemd IP-adres en maakt daarna geen contact meer

Gestart door patrick25Board Synology DSM 5.2

Reacties: 6
Gelezen: 9495
Laatste bericht 17 mei 2015, 09:37:01
door Ben(V)
Geen geluid op Apple TV bij MKV met DTS geluid.

Gestart door FernandoTBoard Video Station

Reacties: 8
Gelezen: 6900
Laatste bericht 12 maart 2014, 10:02:04
door FernandoT
Synology-Forum.nl is een Nederlands gebruikersforum en staat volledig los van het merk Synology. Lees onze privacyverklaring.