Auteur Topic: Kan AutoSub-BootstrapBill niet installeren.  (gelezen 7667 keer)

Offline Hawkens

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 1
  • Berichten: 20
Kan AutoSub-BootstrapBill niet installeren.
« Gepost op: 12 februari 2017, 18:43:13 »
Link van dit Topic gehaald: https://github.com/BenjV/Syno-Package-autosub

Package installeerd niet, heb Python 3.5.1 geinstalleerd, maar bij volgende te klikken blijft de melding verschijnen dat ik Python moet installeren. Wellicht doe ik iets niet goed? Vooralsnog werkt het bij mij niet.

DSM 6.0.2-8451 Update 9

Thanks.
  • Mijn Synology: DS1515+
  • HDD's: 4 x WD10EFRX-68FYTN0
  • Extra's: 1 x SSD Crucial 250G
MCSA 2012 R2 Certified.
Specialism: XenApp and XenDesktop 7.x / RES / VMware

Ben(V)

  • Gast
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #1 Gepost op: 12 februari 2017, 18:46:57 »
Autosub draait alleen onder Python 2.7 en niet onder Python 3.

Offline Hawkens

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 1
  • Berichten: 20
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #2 Gepost op: 12 februari 2017, 18:52:55 »
Ga ik dat even proberen. De melding geeft aan Python 2.7.3-3 of hoger..

Thanks.
  • Mijn Synology: DS1515+
  • HDD's: 4 x WD10EFRX-68FYTN0
  • Extra's: 1 x SSD Crucial 250G
MCSA 2012 R2 Certified.
Specialism: XenApp and XenDesktop 7.x / RES / VMware

Offline Hawkens

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 1
  • Berichten: 20
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #3 Gepost op: 12 februari 2017, 19:02:30 »
Krijg nu de volgende melding na de installatie: "Failed to run the package service"

Mis ik nog iets?

  • Mijn Synology: DS1515+
  • HDD's: 4 x WD10EFRX-68FYTN0
  • Extra's: 1 x SSD Crucial 250G
MCSA 2012 R2 Certified.
Specialism: XenApp and XenDesktop 7.x / RES / VMware

Ben(V)

  • Gast
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #4 Gepost op: 12 februari 2017, 20:27:34 »
Ga ik dat even proberen. De melding geeft aan Python 2.7.3-3 of hoger..

Python 3 is geen hogere versie van python 2.7.
Python 2 en Python 3 zijn twee verschillende omgevingen.

Welke python 2.7 heb je geinstalleerd?
Je moet de versie van de SynoCommunity hebben.
Heb je python 3 eerst verwijderd?

Heb je soms de versie van DSM 5 eerst geprobeerd?

Offline Hawkens

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 1
  • Berichten: 20
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #5 Gepost op: 12 februari 2017, 21:52:20 »
Zoals je merkt ben ik geen Linux kenner :)

Ik heb inderdaad Python 2.7 van de SynoCommunity geinstalleerd. Ik heb eerst de onderstaande tutorial geprobeerd als je daar naar refereert:

https://www.synology-forum.nl/spotweb/nieuwe-spotweb-installatie-tutorial/

Ik krijg sowieso Spotnet ook niet aan de praat. Kan het retrieve.php command niet uitvoeren. Krijg of de melding directory bestaat niet of kan command niet uitvoeren:

/volume1/web/spotweb$ php retrieve.php
PHP Fatal error:  Undefined class constant 'MYSQL_ATTR_FOUND_ROWS' in /volume1/web/spotweb/lib/dbeng/dbeng_pdo_mysql.php on line 28

Fatal error: Undefined class constant 'MYSQL_ATTR_FOUND_ROWS' in /volume1/web/sp

/volume1/web/spotweb$ /usr/local/bin56 retrieve.php
-sh: /usr/local/bin56: No such file or directory

Dus zo was ik aan het zoeken en kwam ik bij jou update package uit..

Enig suggestie waarom niets lijkt te werken?

Thanks.
  • Mijn Synology: DS1515+
  • HDD's: 4 x WD10EFRX-68FYTN0
  • Extra's: 1 x SSD Crucial 250G
MCSA 2012 R2 Certified.
Specialism: XenApp and XenDesktop 7.x / RES / VMware

Ben(V)

  • Gast
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #6 Gepost op: 12 februari 2017, 22:10:30 »
Er zîjn nog maar heel weinig packages van derde partijen die geschikt zijn voor DSM 6 en dat geld dus ook voor spotweb.

Ik heb voor autosub wel een package beschikbaar dat onder DSM 6 werkt, de vraag is of jij de juiste gebruikt hebt, want die melding die jij weergeeft treed op als je het DSM 5 package gebruikt.

Offline Hawkens

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 1
  • Berichten: 20
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #7 Gepost op: 13 februari 2017, 10:38:21 »
Ok, dank voor je reactie. Hoe of waar kan ik met zekerheid het juiste package vinden van Spotweb voor DSM6?

Thanks!
  • Mijn Synology: DS1515+
  • HDD's: 4 x WD10EFRX-68FYTN0
  • Extra's: 1 x SSD Crucial 250G
MCSA 2012 R2 Certified.
Specialism: XenApp and XenDesktop 7.x / RES / VMware

Stephan296

  • Gast
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #8 Gepost op: 13 februari 2017, 18:09:38 »
Spotweb werkt prima in dsm6.
In het spotweb topic staat een link naar een werkende versie. (In de handleiding van Birdy)

Offline MacFreak

  • Bedankjes
  • -Gegeven: 4
  • -Ontvangen: 0
  • Berichten: 35
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #9 Gepost op: 10 maart 2017, 08:27:15 »
Hallo,
Gaat deze topic nu over Spotnet of Autosub Bootstrap Bill ? Volgens mij de laatste; ik heb namelijk precies hetzelfde probleem. Waar kan ik Python vandaan halen en welke versie/uitvoering moet ik hebben dan? Geen MacOS of Windows neem ik aan.
Alvast bedankt, groetjes Tom
  • Mijn Synology: DS216+II
  • HDD's: 2 x WD Red 4TB

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 1137
  • -Ontvangen: 6811
  • Berichten: 39.536
  • Synology is awesome.
    • RAID = BACKUP?
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #10 Gepost op: 10 maart 2017, 08:43:20 »
Waar kan ik Python vandaan halen en welke versie/uitvoering moet ik hebben dan?

SynoCommunity - http://packages.synocommunity.com/ toevoegen in:



Dan onder Gemeenschap:



CS406     DSM 2.0-0731
DS107+    DSM 3.1-1639
DS107+    DSM 3.1-1639
DS508     DSM 4.0-2265
DS111     DSM 6.1.7-15284-3
DS411slim DSM 6.2.4-25556
DS411+II  DSM 6.2.4-25556-2
DS413J    DSM 6.2.3-25426-2
DS1515+   DSM 6.2.4-25556
DS716+II  DSM 6.2.4-25556-3
DS918+    DSM 6.2.4-25556-3
DS220+    DSM 6.2.4-25556-3
-----VMM  DSM 7.0.1-42218-2
RT2600ac  SRM 1.2.5-8227-2
MR2200ac  SRM 1.2.5-8227-2

Offline MacFreak

  • Bedankjes
  • -Gegeven: 4
  • -Ontvangen: 0
  • Berichten: 35
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #11 Gepost op: 10 maart 2017, 08:49:33 »
Bedankt!

Okee het is gelukt om de community toe te voegen, maar krijg dan; "Kan "Python" niet installeren. Dit pakket is niet gepubliceerd door Synology Inc.", terwijl bij toevoegen van de community aangegeven werd dat het door de gemeenschap uitgegeven certificaat automatisch zou worden geaccepteerd.
  • Mijn Synology: DS216+II
  • HDD's: 2 x WD Red 4TB

Offline MacFreak

  • Bedankjes
  • -Gegeven: 4
  • -Ontvangen: 0
  • Berichten: 35
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #12 Gepost op: 10 maart 2017, 08:53:08 »
Zie het al; moest 'Elke uitgever selecteren'.

Nu, krijg ik 'Kan pakketservice niet uitvoeren' na installatie... :S
  • Mijn Synology: DS216+II
  • HDD's: 2 x WD Red 4TB

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 1137
  • -Ontvangen: 6811
  • Berichten: 39.536
  • Synology is awesome.
    • RAID = BACKUP?
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #13 Gepost op: 10 maart 2017, 09:11:24 »
Even getest, bij mij geen probleem:





Probeer eens een reboot.


CS406     DSM 2.0-0731
DS107+    DSM 3.1-1639
DS107+    DSM 3.1-1639
DS508     DSM 4.0-2265
DS111     DSM 6.1.7-15284-3
DS411slim DSM 6.2.4-25556
DS411+II  DSM 6.2.4-25556-2
DS413J    DSM 6.2.3-25426-2
DS1515+   DSM 6.2.4-25556
DS716+II  DSM 6.2.4-25556-3
DS918+    DSM 6.2.4-25556-3
DS220+    DSM 6.2.4-25556-3
-----VMM  DSM 7.0.1-42218-2
RT2600ac  SRM 1.2.5-8227-2
MR2200ac  SRM 1.2.5-8227-2

Ben(V)

  • Gast
Re: Kan AutoSub-BootstrapBill niet installeren.
« Reactie #14 Gepost op: 10 maart 2017, 09:21:46 »
Kan me niets voorstellen bij een python package met zo'n melding.
Python is alleen maar een set bestanden die ergens neer gezet worden en er wordt helemaal niets opgestart bij dat package.

Dat gebeurd pas als je een applicatie opstart die in Python geschreven is.

Overigens denk ik dat je het verkeerde package hebt, want de SynoCommunity heeft een "certificate" van Synology en zou dus te installeren moeten zijn zonder het vinkje aan te moeten zetten van "Elke uitgerver"

Of gooi je de dingen nu door elkaar en ben je nu bezig autosub te installeren?
In dat geval heb je waarschijnlijk het package voor DSM 5 gebruikt, voor DSM 6 moet deze hebben.

https://github.com/BenjV/SYNO-packages/blob/master/AutoSub%20DSM6%20noarch%20V1.1.spk


 

wat kan er niet met php/mysql?

Gestart door AnonymousBoard Web Station

Reacties: 2
Gelezen: 4157
Laatste bericht 10 april 2008, 21:14:21
door Anonymous
Map verwijderen op USB-schijf lukt niet

Gestart door AnonymousBoard Externe harddisks en Printers

Reacties: 1
Gelezen: 3689
Laatste bericht 28 augustus 2006, 10:55:33
door Bob
Fan 106e lawaaierig, slaat niet/nauwelijks af bij standby

Gestart door AnonymousBoard NAS hardware vragen

Reacties: 9
Gelezen: 6814
Laatste bericht 02 januari 2007, 12:21:44
door LeendertB
Norton Ghost and DS106j niet compatible?

Gestart door AnonymousBoard NAS hardware vragen

Reacties: 2
Gelezen: 2992
Laatste bericht 06 oktober 2006, 13:35:38
door Anonymous
Synology 106E komt niet uit standby [SOLVED]

Gestart door MichielBoard NAS hardware vragen

Reacties: 2
Gelezen: 2712
Laatste bericht 11 december 2006, 21:16:06
door Anonymous