Auteur Topic: ‘Error Code: 1603’ bij het installeren van de nieuwste versie van Java  (gelezen 7896 keer)

Offline wimbot

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 2
Mijn Synology DS214+ vraagt om de installatie van de nieuwste versie van Java.

Bij het installeren van deze versie krijg ik de volgende fout melding:

‘Error Code: 1603’

Weet iemand wat hier aan de hand is en hoe ik dit kan oplossen?
  • Mijn Synology: DS214+
  • HDD's: 2 x WD30EZRX

Offline MMD

  • MVP
  • *
  • Bedankjes
  • -Gegeven: 102
  • -Ontvangen: 461
  • Berichten: 2.360
Re: ‘Error Code: 1603’ bij het installeren van de nieuwste versie van Java
« Reactie #1 Gepost op: 16 november 2014, 10:35:18 »
De meest voor de hand liggende oorzaak die ik tegenkom op het net zou kunnen zijn dat de oude versie niet eerst verwijderd is. Er zijn echter tal van oorzaken voor deze foutcode.

Als je een nieuw versie nummer (Java 8?) installeert zul je eerst de oude moeten verwijderen.
Als het Java versie nummer eerst 7 was en je probeert versie 8 te installeren zal de installer de 7 niet/niet goed verwijderen. Dit geldt ook als je van 6 naar 7 gaat.
Binnen hetzelfde versie nummer zal het wel goed gaan.

En offline met de browser dicht Java installeren. Op deze manier sluit je dan naar mijn idee de meest voor de hand liggende oorzaak(en) uit.
Ervan uitgaande dat je op Windows zit.

Offline peter2772

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 4
Re: ‘Error Code: 1603’ bij het installeren van de nieuwste versie van Java
« Reactie #2 Gepost op: 16 november 2014, 20:03:04 »
Synology DS211j; DSM 5.1-5004;

Ik kreeg onlangs bericht dat mijn Embedded Java 7 een update nodig had. Ik naar de Oracle website, gedownload : ejre-7u71-fcs-b14-linux-arm-sflt-headless-26_sep_2014 .

Bij de installatie procedure eerst zoals gebruikelijk de vorige Java versie verwijderd en dan via het Package center "Gemeenschap" geprobeerd de nieuwe (?) Java te installeren.
Foutmelding :  Java SE Embedded 7 : Dit pakket bevat geen digitale handtekening en installatie werd geweigerd.

Bij nader inzien was er helemaal geen update nodig : ik had het 26sep2014 pakket nog bewaard na de vorige installatie. Die is in september zonder problemen geinstalleerd! Maar nu wil niets meer :  ook een eerdere versie (mei2014) gaf dezelfde foutmelding. Handmatig installeren lukte ook niet : "niet het juiste filetype".

IK weet dus vrijwel zeker dat het niet aan Oracle ligt : de javapaketten zijn niet corrupt o.i.d.
Meest waarschijnlijk reden is de nieuwste DSM versie die ik onlangs geinstalleerd heb (of die daarvoor, elke DSM versie tussen eind sept 2014 en nu kan het geweest zijn).

Wie weet raad met -m.i.- deze bug in DSM? Ik kan nu niet langer de Minim-server gebruiker : die heeft Java 7 nodig.

Offline peter2772

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 4
Re: ‘Error Code: 1603’ bij het installeren van de nieuwste versie van Java
« Reactie #3 Gepost op: 16 november 2014, 20:23:47 »
Kijk : het helpt om even het probleem op te schrijven : Kreeg een idee en ja hoor : het werkt weer!
Bij het "package center" naar "Instellingen" gekeken. Daar staan onder "vertrouwens niveau" 3 mogelijkheden :

1) Alleen Synology
2) Alleen Synology en vertrouwde uitgevers
3) Elke uitgever

Bij mij stond aangevinkt 2). Toen ik 3) koos ging de installatie van Java weer normaal goed.

Het ligt dus toch aan een DSM update : óf Synology heeft Oracle eruit gegooid als vertrouwde uitgever óf bij de DSM update is ongevraagd het ingestelde vetrouwens niveau veranderd.

Offline Ben(V)

  • MVP
  • *
  • Bedankjes
  • -Gegeven: 65
  • -Ontvangen: 1353
  • Berichten: 7.442
Re: ‘Error Code: 1603’ bij het installeren van de nieuwste versie van Java
« Reactie #4 Gepost op: 16 november 2014, 20:41:41 »
Ligt niet aan oracle, maar aan de package bouwer.
In DSM 5.1 zijn nieuwe checks ingebouwd, maar alle packages zijn nog niet aangepast.
  • Mijn Synology: DS414
  • HDD's: 4 x 3TB WD30EFRX
  • Extra's: DS116

Offline MMD

  • MVP
  • *
  • Bedankjes
  • -Gegeven: 102
  • -Ontvangen: 461
  • Berichten: 2.360
Re: ‘Error Code: 1603’ bij het installeren van de nieuwste versie van Java
« Reactie #5 Gepost op: 16 november 2014, 21:29:46 »
Heren, ik vermoed dat het hier gaat om de Java die op de PC/Laptop is geïnstalleerd.
DSM geeft daar een melding van, dat heb ik inmiddels ook 2x gehad.
In april toen ik de NAS kocht en 2 weken geleden toen ik een nieuwe kreeg na RMA.

Offline wimbot

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 2
Re: ‘Error Code: 1603’ bij het installeren van de nieuwste versie van Java
« Reactie #6 Gepost op: 17 november 2014, 08:51:54 »
Klopt . Het gaat om de java versie die geïnstalleerd is op mijn desktop.

Ik heb nu de oude java-versie verwijderd en opnieuw geprobeerd om de nieuwe versie te installeren, maar ik krijg nog steeds dezelfde foutmelding. 
  • Mijn Synology: DS214+
  • HDD's: 2 x WD30EZRX

Offline Richard67

  • Bedankjes
  • -Gegeven: 43
  • -Ontvangen: 59
  • Berichten: 370
    • Q&D Website
Re: ‘Error Code: 1603’ bij het installeren van de nieuwste versie van Java
« Reactie #7 Gepost op: 17 november 2014, 15:17:26 »
Die 1603 error lijkt mij te komen uit de Windows installer van Java. Kijk eens of je hier de oplossing kunt vinden: http://www.adminarsenal.com/admin-arsenal-blog/beat-java-error-1603-when-deploying
  • Mijn Synology: 1511+
  • HDD's: 5x WD20EFRX
  • Extra's: 2GB RAM
Who on earth is General Failure and why the hell is he reading my hard drive?


 

Kan surveillance station niet verwijderen, niet installeren en niet repareren

Gestart door DrLivingstonedBoard Surveillance Station

Reacties: 13
Gelezen: 3666
Laatste bericht 16 augustus 2015, 13:06:00
door theboss86
DS Audio / Audio Station opnieuw installeren

Gestart door goldenwonderBoard Audio Station

Reacties: 12
Gelezen: 1864
Laatste bericht 21 november 2016, 09:59:40
door goldenwonder
"Kan pakket niet installeren" HELLUP!!!

Gestart door vondorknlBoard SABnzbd (usenet)

Reacties: 4
Gelezen: 2678
Laatste bericht 25 januari 2009, 15:36:07
door vondorknl
Installeren "Remote Agent for Linux servers"

Gestart door UniverseBoard Algemeen

Reacties: 1
Gelezen: 3131
Laatste bericht 08 juli 2008, 10:31:37
door eovermeer
"u moet uw photostation-pakket installeren of upgraden"

Gestart door peterk36Board Photo Station / Blog

Reacties: 1
Gelezen: 1301
Laatste bericht 23 september 2014, 23:07:46
door Goner
Synology-Forum.nl is een Nederlands gebruikersforum en staat volledig los van het merk Synology.