Auteur Topic: PPTP werkt, maar openVPN werkt niet  (gelezen 4440 keer)

Offline albydetweede

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 27
PPTP werkt, maar openVPN werkt niet
« Gepost op: 29 december 2015, 17:28:26 »
Hallo allemaal,

Met als doel via het ip-adres van thuis het internet op te gaan op een andere locatie, heb ik VPN ingesteld op m'n Synology DS415+.

Eerst met het, zo hoorde ik, minder veilige PPTP kreeg ik de VPN aan de praat. Op een ander adres gaf m'n laptop (via www.watismijnip.nl) netjes m'n ip-adres van thuis aan. De port forward heb ik ingesteld in m'n Experiabox v10 van KPN (glasvezel).

Nu ben ik ook aan de slag gegaan met het veiligere openVPN. In de synology deze aangezet en een account met de nodige rechten aangemaakt en aan dat account openVPN dus toegewezen. Van de openVPN heb ik de benodigde bestanden (ca.crt en openvpn.ovpn) geëxporteerd en deze geplaatst in deze map: C:\Program Files\OpenVPN\config
In deze map een extra bestand geplaatst genaamd password.txt met op de bovenste regen de gebruikersnaam en op de tweede regel het wachtwoord. Het bestand ca.crt heb ik uitgevoerd om het certificaat te installeren. Dat had ik al eens eerder gedaan. geeft dat geen conflict?
Het bestand openvpn.ovpn heb ik aangepast en ziet er zo uit:

dev tun
tls-client

remote (mijn ipadres zoals zichtbaar op www.watismijnip.nl) 1194

float

redirect-gateway def1

#dhcp-option DNS DNS_IP_ADDRESS

pull

script-security 2

ca ca.crt

comp-lzo

reneg-sec 0

auth-user-pass password.txt

___________________________________________________________________________________
Met DNS heb ik niets gedaan. Dat is toch als je geen vast ip-adres hebt? Heb ik bij KPN eigenlijk een vast ipadres? Ik vul nu het adres in van www.watismijnip.nl in op de regel waar poortnummer 1194 staat.

Dat poortnummer 1194 heb ik geforward naar m'n NAS. Dat ziet er zo uit in m'n experiabox 10. Heb ik dat goed gedaan? (zie bijlage)

_________________________________________________________________________________________

Als ik met het programma "OpenVPN GUI" verbinding probeer te maken, dan zegt hij dat er een verbinding gemaakt is, maar dat gaat niet goed. Zie hier de foutmeldingen:

Tue Dec 29 16:49:04 2015 Warning: cannot open --log file: C:\Program Files\OpenVPN\log\openvpn.log: Toegang geweigerd.   (errno=5)
Tue Dec 29 16:49:04 2015 OpenVPN 2.3.8 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Aug  4 2015
Tue Dec 29 16:49:04 2015 library versions: OpenSSL 1.0.1p 9 Jul 2015, LZO 2.08
Tue Dec 29 16:49:04 2015 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Tue Dec 29 16:49:05 2015 UDPv4 link local (bound): [undef]
Tue Dec 29 16:49:05 2015 UDPv4 link remote: [AF_INET]86.xx.xx.xxx:1194
Tue Dec 29 16:49:05 2015 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Tue Dec 29 16:49:05 2015 [synology.com] Peer Connection Initiated with [AF_INET]86.xx.xxx.xxx:1194
Tue Dec 29 16:49:07 2015 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Tue Dec 29 16:49:07 2015 open_tun, tt->ipv6=0
Tue Dec 29 16:49:07 2015 TAP-WIN32 device [Ethernet 2] opened: \\.\Global\{8F55E470-C1D6-47A6-8A98-448B35690B33}.tap
Tue Dec 29 16:49:07 2015 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.8.0.6/xxx.xxx.xxx.252 on interface {8F55E470-C1C6-47B6-8A98-448C35690B33} [DHCP-serv: 10.8.0.5, lease-time: 31536000]
Tue Dec 29 16:49:12 2015 ROUTE: route addition failed using CreateIpForwardEntry: Toegang geweigerd.   [status=5 if_index=6]
Tue Dec 29 16:49:12 2015 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Tue Dec 29 16:49:12 2015 ERROR: Windows route add command failed [adaptive]: returned error code 1
Tue Dec 29 16:49:12 2015 ROUTE: route addition failed using CreateIpForwardEntry: Toegang geweigerd.   [status=5 if_index=13]
Tue Dec 29 16:49:12 2015 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Tue Dec 29 16:49:12 2015 ERROR: Windows route add command failed [adaptive]: returned error code 1
Tue Dec 29 16:49:12 2015 ROUTE: route addition failed using CreateIpForwardEntry: Toegang geweigerd.   [status=5 if_index=13]
Tue Dec 29 16:49:12 2015 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Tue Dec 29 16:49:12 2015 ERROR: Windows route add command failed [adaptive]: returned error code 1
Tue Dec 29 16:49:12 2015 ROUTE: route addition failed using CreateIpForwardEntry: Toegang geweigerd.   [status=5 if_index=13]
Tue Dec 29 16:49:12 2015 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Tue Dec 29 16:49:12 2015 ERROR: Windows route add command failed [adaptive]: returned error code 1
Tue Dec 29 16:49:12 2015 ROUTE: route addition failed using CreateIpForwardEntry: Toegang geweigerd.   [status=5 if_index=13]
Tue Dec 29 16:49:12 2015 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Tue Dec 29 16:49:12 2015 ERROR: Windows route add command failed [adaptive]: returned error code 1
Tue Dec 29 16:49:12 2015 ROUTE: route addition failed using CreateIpForwardEntry: Toegang geweigerd.   [status=5 if_index=13]
Tue Dec 29 16:49:12 2015 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Tue Dec 29 16:49:12 2015 ERROR: Windows route add command failed [adaptive]: returned error code 1
Tue Dec 29 16:49:12 2015 Initialization Sequence Completed

In verband met welliicht privacy gevoeligheid heb ik her en der van XXX gezet.

__________________________________________________________________________________________________
Ik neem aan dat de port forward niet werkt en toch geeft hij een verbinding aan. Ik kan ook gewoon internetten vanaf een ander ip-adres. Hij wijzigt alleen niet het ip-adres in die van thuis. De # is weg voor de regel "redirect-gateway def1". Dat zou ervoor zorgen dat ik via het thuis ipadres online ga, maar als de portforward niet werkt, werkt dat dus ook niet.

Ik weet niet wat ik verkeerd doe. Wie weet er raad?

Plan is ook nog om via een webmap (netdrive of via verkenner) vanaf een ander ip toegang te hebben tot de bestanden op m'n NAS. Ik dacht dat dat ook handig zou gaan als ik het ip van thuis zou hebben, maar met het werkende PPTP deed de netwerkmap op de NAS het niet, terwijl ik wel toegang heb als ik thuis ben. Dit even ter zijde. Eest maar eens kijken of ik openVPN aan de praat krijg.


  • Mijn Synology: DS415+

Offline Birdy

  • Global Moderator
  • MVP
  • *
  • Bedankjes
  • -Gegeven: 1139
  • -Ontvangen: 6812
  • Berichten: 39.582
  • Synology is awesome.
    • RAID = BACKUP?
Re: PPTP werkt, maar openVPN werkt niet
« Reactie #1 Gepost op: 29 december 2015, 17:57:15 »
V.w.b.
Citaat
ERROR: Windows route add command failed
lijkt mij een gebruiker rechten probleem op je PC.
Misschien heb je hier wat aan ?


CS406     DSM 2.0-0731
DS107+    DSM 3.1-1639
DS107+    DSM 3.1-1639
DS508     DSM 4.0-2265
DS111     DSM 6.1.7-15284-3
DS411slim DSM 6.2.4-25556
DS411+II  DSM 6.2.4-25556-2
DS413J    DSM 6.2.3-25426-2
DS1515+   DSM 6.2.4-25556
DS716+II  DSM 6.2.4-25556-3
DS918+    DSM 6.2.4-25556-3
DS220+    DSM 6.2.4-25556-3
-----VMM  DSM 7.0.1-42218-2
RT2600ac  SRM 1.2.5-8227-2
MR2200ac  SRM 1.2.5-8227-2

Offline Pippin

  • MVP
  • *
  • Bedankjes
  • -Gegeven: 103
  • -Ontvangen: 522
  • Berichten: 2.712
  • a.k.a. MMD
Re: PPTP werkt, maar openVPN werkt niet
« Reactie #2 Gepost op: 29 december 2015, 18:20:48 »

Op je laptop moet je OpenVPN als administrator starten.
DS414
OpenVPN #1: Beter beveiligen OpenVPN #2: Beter beveiligen als client

I gloomily came to the ironic conclusion that if you take a highly intelligent person and give them the best possible, elite education, then you will most likely wind up with an academic who is completely impervious to reality.
Halton Arp

Offline albydetweede

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 27
Re: PPTP werkt, maar openVPN werkt niet
« Reactie #3 Gepost op: 29 december 2015, 18:47:38 »
Dat maakte ik ook al op uit het Engelstalige verhaal. Het account waar ik op werk (op de laptop) is echter een Administrator-account. Ik zal het straks even testen via een open wifi van één van de buren. Ik klik dan rechts op "OpenVPN Gui"....als administrator uitvoeren. Ik doe het straks omdat er nu wat film staat te streamen naar de tv.
  • Mijn Synology: DS415+

Offline albydetweede

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 27
Re: PPTP werkt, maar openVPN werkt niet
« Reactie #4 Gepost op: 29 december 2015, 19:19:54 »
Bizar zeg. Het werkt. Via de wifi van één van de buren zit ik op het ip-adres van thuis. Het starten van "OpenVPN GUI" als administrator werkt. Ik meld me echter bij windows aan met een administrator account. Dat vind ik zo vreemd. Nu uitzoeken (oplossing geloof ik op Engelse pagina) hoe ik het automatisch als admin laat starten.
  • Mijn Synology: DS415+

Offline Pippin

  • MVP
  • *
  • Bedankjes
  • -Gegeven: 103
  • -Ontvangen: 522
  • Berichten: 2.712
  • a.k.a. MMD
Re: PPTP werkt, maar openVPN werkt niet
« Reactie #5 Gepost op: 29 december 2015, 19:22:47 »
Onder de eigenschappen van de snelkoppeling kun je dat aanvinken.
DS414
OpenVPN #1: Beter beveiligen OpenVPN #2: Beter beveiligen als client

I gloomily came to the ironic conclusion that if you take a highly intelligent person and give them the best possible, elite education, then you will most likely wind up with an academic who is completely impervious to reality.
Halton Arp

Offline albydetweede

  • Bedankjes
  • -Gegeven: 0
  • -Ontvangen: 0
  • Berichten: 27
Re: PPTP werkt, maar openVPN werkt niet
« Reactie #6 Gepost op: 29 december 2015, 19:38:36 »
Ik heb het net gevonden en wilde het al even melden hier. Rechter muisknop op snelkoppeling "openVPN Gui", dan tabblad "Compatibiliteit". Daar een vinkje zetten bij: "Dit programma als administrator uitvoeren".

Bedankt jullie voor het meedenken. Het heeft me dagen gekost voordat ik alles begreep. Uiteindelijk komt alles weer goed.
  • Mijn Synology: DS415+


 

VPN Server package 1.1-2198 PPTP probleem

Gestart door e92Board VPN Server

Reacties: 3
Gelezen: 1628
Laatste bericht 23 april 2013, 21:03:43
door Mr.Hoek
VPN PPTP

Gestart door LenslarqueBoard Synology DSM 5.1 en eerder

Reacties: 5
Gelezen: 2611
Laatste bericht 06 maart 2013, 11:45:03
door vdhoek1972
Mappen delen tussen 2 Synology's via PPTP VPN

Gestart door MAdDBoard VPN Server

Reacties: 1
Gelezen: 1548
Laatste bericht 01 mei 2013, 13:01:42
door rgroothuis
PPTP verbinding Hoe verder?

Gestart door jellerubenBoard VPN Server

Reacties: 22
Gelezen: 5372
Laatste bericht 06 juni 2014, 07:10:40
door Heppieboeddah
PPTP server maximale aantal verbindingen

Gestart door polcompBoard VPN Server

Reacties: 2
Gelezen: 2049
Laatste bericht 19 april 2012, 15:27:34
door Nelesss